summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-08-07 19:18:44 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-08-07 19:21:01 +0200
commitc3e1a88b5c9e6a247dfcb5cf5c7fc295d862e327 (patch)
treecd5bca255a67253b2dead83132ec278c200b9adb
parentgui-apps/foot-terminfo: add 1.15.3 (diff)
downloadgentoo-c3e1a88b5c9e6a247dfcb5cf5c7fc295d862e327.tar.gz
gentoo-c3e1a88b5c9e6a247dfcb5cf5c7fc295d862e327.tar.bz2
gentoo-c3e1a88b5c9e6a247dfcb5cf5c7fc295d862e327.zip
gui-apps/foot: add 1.15.3
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.15.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index 6cb2367b0777..cd9204913b71 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -5,3 +5,4 @@ DIST foot-1.14.0.tar.gz 509863 BLAKE2B fe7e26c3c70e99c00a121e1214f0003dbc8fc986a
DIST foot-1.15.0.tar.gz 520829 BLAKE2B e86dba4c000ae3b290d207a2edef5e3b4240d27dd00c7e174312c3921ce670950c3396bd0d557733c87bcbeacc28fc9768916dc12fc703e5ebfd175afa818f01 SHA512 b0d4ad025010e2dbe30e1cfbc5d41c7dabc2d2d99872193134ddbca043d0d63daf85f2e81bcfa4aabcf7335c38e952bb1e46a9d28a1cd8ac62fc14c6bf87cb20
DIST foot-1.15.1.tar.gz 523399 BLAKE2B 6e9296dcb8fd16fb77ec1e7a7668b46da31f83343f6b5fcafdb2514570ec7a356e1ba6308024331b66fdaca34eb86fd69dea6d5ab71a576ae13740a03d4245b7 SHA512 14605ba6e18b7ffc0961a3f00d275af2d885ec3d194123406d4fef21c6ec193c37ddee0a58f3a70853a72aabdbfc768bfc5fa1c516ad6cb669056c1c6dea990f
DIST foot-1.15.2.tar.gz 524743 BLAKE2B 7c6f573e733210f532238eb0d2385d49f61fcb531265ff1474b93cd092c8d860f27b11e6b36c506379d7874b9cc285825f56518817a2623fdde93b7c3d0e4fc6 SHA512 931231e0518950d3ac42625befab63ecc9a253bb870ea4c439d1110c40b31c15d049b9fc1e2a6282927737a9f6d7cd3278d42dffa6a57c3c1366e342e1e79622
+DIST foot-1.15.3.tar.gz 524297 BLAKE2B 3909a2cd9b7df1dbc6305a14675494d65874d1af2ad550fcbc7fe4b33c1a2bb2287029922daedbea8c9bfa5a855e1dd5c01fa2011bc0f9ebddca8565a44da591 SHA512 c27fefd40518382a184c590d02eee69deecf665759e909de6f4a61234159df7a1b38061eb9fd776ed205f10a556d5bf7520f5515fa9cec22a683f2f25d7495f8
diff --git a/gui-apps/foot/foot-1.15.3.ebuild b/gui-apps/foot/foot-1.15.3.ebuild
new file mode 100644
index 000000000000..37a811c34809
--- /dev/null
+++ b/gui-apps/foot/foot-1.15.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+grapheme-clustering test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ grapheme-clustering? (
+ dev-libs/libutf8proc:=
+ media-libs/fcft[harfbuzz]
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=dev-libs/tllist-1.1.0
+ dev-libs/wayland-protocols
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3[-minimal]
+ ~gui-apps/foot-terminfo-${PV}
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+ # disable the systemd dep, we install the unit file manually
+ sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature grapheme-clustering)
+ $(meson_use test tests)
+ -Dthemes=true
+ -Dime=true
+ -Dterminfo=disabled
+ )
+ meson_src_configure
+
+ sed 's|@bindir@|/usr/bin|g' "${S}"/foot-server.service.in > foot-server.service || die
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md LICENSE )
+ meson_src_install
+
+ # foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+ # we handle this via DOCS and dodoc instead.
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+ systemd_douserunit foot-server.service "${S}"/foot-server.socket
+}