summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-13 00:31:00 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-13 00:33:19 -0500
commita88ace55b415065fd71800db672557e54e065969 (patch)
treec758b44a32a7a7198b93f2fe4a8d050450bd8e2b
parentsys-apps/busybox: version bump #564246 (diff)
downloadgentoo-a88ace55b415065fd71800db672557e54e065969.tar.gz
gentoo-a88ace55b415065fd71800db672557e54e065969.tar.bz2
gentoo-a88ace55b415065fd71800db672557e54e065969.zip
sys-apps/busybox: move USE=static default to the profile #468580
Since busybox is pulled in via the linux profile (as we use it as the rescue shell there), we should have the static USE flag set via the profile too rather than the ebuild. This way we apply it only to the subset of profiles where it makes sense. For the live ebuild, we also switch to REQUIRED_USE since package.use is able to override make.defaults (which is where USE=pam is set). We can see how users react to this behavior before pulling it back into the released versions.
-rw-r--r--profiles/default/linux/package.use5
-rw-r--r--profiles/embedded/package.use2
-rw-r--r--sys-apps/busybox/busybox-1.24.1.ebuild2
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild6
4 files changed, 9 insertions, 6 deletions
diff --git a/profiles/default/linux/package.use b/profiles/default/linux/package.use
index 8dd735c8cf1e..827b0534890d 100644
--- a/profiles/default/linux/package.use
+++ b/profiles/default/linux/package.use
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Mike Frysinger <vapier@gentoo.org> (12 Nov 2015)
+# We want busybox statically linked by default as it is the system rescue shell.
+# But we cannot statically link pam, so turn that off by default. #468580
+sys-apps/busybox -pam static
+
# Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> (13 Feb 2011)
# Disable deprecated bsddb module of Python 2 by default.
=dev-lang/python-2* -berkdb
diff --git a/profiles/embedded/package.use b/profiles/embedded/package.use
index 49943b14e954..7dda9d81fe00 100644
--- a/profiles/embedded/package.use
+++ b/profiles/embedded/package.use
@@ -1 +1 @@
-sys-apps/busybox make-symlinks
+sys-apps/busybox make-symlinks static
diff --git a/sys-apps/busybox/busybox-1.24.1.ebuild b/sys-apps/busybox/busybox-1.24.1.ebuild
index 9f87f6ef1275..f385277ea6b2 100644
--- a/sys-apps/busybox/busybox-1.24.1.ebuild
+++ b/sys-apps/busybox/busybox-1.24.1.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug ipv6 livecd make-symlinks math mdev -pam selinux sep-usr +static syslog systemd"
+IUSE="debug ipv6 livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
RESTRICT="test"
COMMON_DEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 3fd4db957adb..af1e7532d1ab 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -21,7 +21,8 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug ipv6 livecd make-symlinks math mdev -pam selinux sep-usr +static syslog systemd"
+IUSE="debug ipv6 livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
+REQUIRED_USE="pam? ( !static )"
RESTRICT="test"
COMMON_DEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
@@ -131,9 +132,6 @@ src_configure() {
busybox_config_option n UDHCPC6
fi
- if use static && use pam ; then
- ewarn "You cannot have USE='static pam'. Assuming static is more important."
- fi
busybox_config_option $(usex static n pam) PAM
busybox_config_option static STATIC
busybox_config_option syslog {K,SYS}LOGD LOGGER