summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-22 13:12:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-22 13:16:16 +0200
commita7409f5c5ad4a5caff628ad943ffbb9812960468 (patch)
treeab61c5db1672e21d09f087c912560a09e9b14487
parentdev-python/bibtexparser: Bump to 1.4.1 (diff)
downloadgentoo-a7409f5c5ad4a5caff628ad943ffbb9812960468.tar.gz
gentoo-a7409f5c5ad4a5caff628ad943ffbb9812960468.tar.bz2
gentoo-a7409f5c5ad4a5caff628ad943ffbb9812960468.zip
dev-python/setuptools-scm: Bump to 8.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools-scm/Manifest1
-rw-r--r--dev-python/setuptools-scm/setuptools-scm-8.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/setuptools-scm/Manifest b/dev-python/setuptools-scm/Manifest
index 2f8fed199f77..f28feba89e0d 100644
--- a/dev-python/setuptools-scm/Manifest
+++ b/dev-python/setuptools-scm/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-scm-8.0.1.tar.gz 71827 BLAKE2B 4011879490a02f5bb8b4fa0292ee696010cca9cb5c322854f2c342b4c02a86f7a31535c3fe7b4e6eab4fb77c90a469714227c1487ee7e1c1d4de3a4db1137b6b SHA512 05c087cbcb8bf2f03d68cf91e5545c25dea85d61d16c26194ade42a5e78a573f1adc4265897998d4b151834e994b3aa32e02a1eb2fa103a4cd1f3c8e3b78d8d4
DIST setuptools-scm-8.0.2.tar.gz 72614 BLAKE2B 80dedf269f504a632f6b8c8ceafc28948e359825b926ac851219171db4015856aaebde8c0e8ee81dc807bb1b25010d686a039063922046dc4d72beacf14914c6 SHA512 1a636f452cbe61fc1bc6fca49032e7d12b80fe5d8931f292cfa295d6787fb9273fd7f3887f3f74d60c1da19f4e2f676d038fd860c0410838225cad95e6375f9b
+DIST setuptools-scm-8.0.3.tar.gz 72824 BLAKE2B f45b3bf67cc259e18fbd3a155d10967cf7c6a9df69d6bff7cc452236da3c3e1d0205ff7f5523c5bfdcbdbf5056e00f06c21dc1178edf14b386a0b89e95c947c1 SHA512 7002da1abdabbf617fb92b94aa04f6fe90aa5cbe26ae7ff8a9df0c53b35e8d13e6294ed38373d081ccafe375b376d52e72d5c7a031dbfb356aa0ee3221641096
DIST setuptools_scm-7.1.0.tar.gz 71904 BLAKE2B be5ae215dadcc290290762b732434258409ecc2d71cdf1332ffe73431effae7cbc33e052a718efd952be79350171ed3e468492fc719bc08750dc23364fb0ee9d SHA512 bd7260672c213db6b8c5842dbb6ac69e69ce040777865c935033971f65d905bd8e6b54e174190a924e452c302e69d4c1de231cbc8f603176ba013a739840dad3
diff --git a/dev-python/setuptools-scm/setuptools-scm-8.0.3.ebuild b/dev-python/setuptools-scm/setuptools-scm-8.0.3.ebuild
new file mode 100644
index 000000000000..bd4c320ce6c3
--- /dev/null
+++ b/dev-python/setuptools-scm/setuptools-scm-8.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage versions by scm tags via setuptools"
+HOMEPAGE="
+ https://github.com/pypa/setuptools_scm/
+ https://pypi.org/project/setuptools-scm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# there's an optional dep on rich for cute logs
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-vcs/git
+ !sparc? (
+ dev-vcs/mercurial
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the usual nondescript gpg-agent failure
+ testing/test_git.py::test_git_getdate_signed_commit
+
+ # fetching from the Internet
+ testing/test_regressions.py::test_pip_download
+
+ # calls flake8, unpredictable
+ testing/test_functions.py::test_dump_version_flake8
+ )
+
+ if has_version dev-python/nose; then
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/892639
+ testing/test_integration.py::test_pyproject_support
+ )
+ fi
+
+ epytest
+}