summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marius.brehler+gentoo@googlemail.com>2019-10-21 10:39:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-21 00:39:37 +0100
commita3e173a4cf9b6f3fdd96937d51c8fc2d5d58ed9b (patch)
treeaae93cbc1f76edd95026e1e9aea66d086893398e
parentdev-python/entrypoints: Add setuptools as dependency (diff)
downloadgentoo-a3e173a4cf9b6f3fdd96937d51c8fc2d5d58ed9b.tar.gz
gentoo-a3e173a4cf9b6f3fdd96937d51c8fc2d5d58ed9b.tar.bz2
gentoo-a3e173a4cf9b6f3fdd96937d51c8fc2d5d58ed9b.zip
dev-python/entrypoints: Version bump to 0.3
Bug: https://bugs.gentoo.org/667902 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Marius Brehler <marius.brehler+gentoo@googlemail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/entrypoints/Manifest1
-rw-r--r--dev-python/entrypoints/entrypoints-0.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/entrypoints/Manifest b/dev-python/entrypoints/Manifest
index 3c82fa566540..4c2a46869486 100644
--- a/dev-python/entrypoints/Manifest
+++ b/dev-python/entrypoints/Manifest
@@ -1 +1,2 @@
DIST entrypoints-0.2.3.tar.gz 11219 BLAKE2B ae7745a075d564b3cc25a0580ae9f30f6e1a0b4bca7315c4fc3700408e4ab3762831212a451eb937ab94096d1db5c1478980b216dea7cfb95a8577d6337534a0 SHA512 dbf8085652e50cbdbe137ae655ef765cff58bdaa6beefebf1383dcd96dfcbf9c92580c09e9a58de7893aebdd7b2a701ef8d13a56ef0fa9a3d9ef7a5bd1d9b11b
+DIST entrypoints-0.3.tar.gz 12315 BLAKE2B f548d98eeb9dcf5760b26f66e5dec0849c9a9027cd68447c07a585e7b80f79a7c66712d0dd270b6960db167d26f9cf0c9c221edd21f2692c2221d36e952ede65 SHA512 aa1274362d3a4b00266103319ca51aa266605b4999c89a9d0673eb61bfae9e646cb0ec6b86c95544493f6fe048385a2c7641d64adca8f45815546fb1e663c858
diff --git a/dev-python/entrypoints/entrypoints-0.3.ebuild b/dev-python/entrypoints/entrypoints-0.3.ebuild
new file mode 100644
index 000000000000..dc4147fe6d0c
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.2.1-init.py.patch
+)
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}