summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-12 19:36:15 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-12 19:39:55 +0100
commit9ebeb84b7e237ff0ba6073fd05f4f756cd206336 (patch)
treea857a9241d284a8c29b7bc1361b36ebd7eb1f973
parentdev-python/xcffib: Bump to 1.7.0 (diff)
downloadgentoo-9ebeb84b7e237ff0ba6073fd05f4f756cd206336.tar.gz
gentoo-9ebeb84b7e237ff0ba6073fd05f4f756cd206336.tar.bz2
gentoo-9ebeb84b7e237ff0ba6073fd05f4f756cd206336.zip
dev-python/pyscard: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index b3ad876e6449..52ec108e08c7 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.2.0.tar.gz 154847 BLAKE2B 4941ddb8b5ba38855eb69d61432241fc181e7fff7c181eb9d40ae03f0e4ce5818483d2ea35e25e92033f946e5f3e17aad297c02b3c90def91f79c24941bc80bf SHA512 91ceeab576345ff7f2e9d173399ab4d2ddebd26dab613fba33b7620253aea81645d6efdf0d365724a34cec8e9fd4f76cd43801d925a94e058ff797e5c0a41b73
+DIST pyscard-2.2.1.tar.gz 156518 BLAKE2B b68dace8a9b4b6cdae20b23d6e7d8838e0ad64e229d5a3a5e4a8fc5c1edeb16a6d7bd162c57cfdd7d5e5c56c0370f121a71e498e463b42b509bc97dce10ef14c SHA512 7a09211743c56473e7c1d034acf4b08402b41462da36b35fe45617511dc9bc5fa704e0d1d5102277a44c4aee216e84b019b5cff188eda255b32de0c7517c58d3
diff --git a/dev-python/pyscard/pyscard-2.2.1.ebuild b/dev-python/pyscard/pyscard-2.2.1.ebuild
new file mode 100644
index 000000000000..68e78542f37b
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}