summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-05-26 03:05:00 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-05-26 04:02:58 -0500
commit8715822c57cf2a409b1515413fa564da5ccf3303 (patch)
tree74b1eba35988650b2405d562d7597fff7bc079b8
parentdev-db/postgresql: add 16_beta1 (diff)
downloadgentoo-8715822c57cf2a409b1515413fa564da5ccf3303.tar.gz
gentoo-8715822c57cf2a409b1515413fa564da5ccf3303.tar.bz2
gentoo-8715822c57cf2a409b1515413fa564da5ccf3303.zip
dev-python/magic-wormhole-mailbox-server: QA
- add missing test dependency on dev-python/mock - as requested in bug #907117, do not use vcs-snapshot - even though this makes for much nicer paths when using commit snapshots... Closes: https://bugs.gentoo.org/907199 Bug: https://bugs.gentoo.org/907117 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.4.1_p20230525.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.4.1_p20230525.ebuild b/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.4.1_p20230525.ebuild
index f5769517ec9f..47035e89b80c 100644
--- a/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.4.1_p20230525.ebuild
+++ b/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.4.1_p20230525.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_USE_PEP517=setuptools
# Version 0.4.1 with additional upstream fixes for python 3.11 support
COMMIT_SHA1="39672ae95a2635ba9daaba62f483aa75bfd80a22"
-inherit distutils-r1 vcs-snapshot
+inherit distutils-r1
DESCRIPTION="Mailbox server for magic-wormhole"
HOMEPAGE="https://magic-wormhole.readthedocs.io/en/latest/ https://pypi.org/project/magic-wormhole-mailbox-server/"
@@ -18,12 +18,15 @@ SRC_URI="https://github.com/magic-wormhole/${PN}/archive/${COMMIT_SHA1}.tar.gz -
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/${P}.gh"
+S="${WORKDIR}/magic-wormhole-mailbox-server-${COMMIT_SHA1}"
RDEPEND="
dev-python/autobahn[${PYTHON_USEDEP}]
dev-python/twisted[ssl,${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/treq[${PYTHON_USEDEP}] )"
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ )"
distutils_enable_tests pytest