summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 14:14:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 16:50:33 -0500
commit74f2e7c40bf6cb254da2118d311bb570363cf3e7 (patch)
tree919cd59facffe0287b49c84831329bddf7aeff75
parentapp-editors/jedit: Version bump to 5.4.0 (diff)
downloadgentoo-74f2e7c40bf6cb254da2118d311bb570363cf3e7.tar.gz
gentoo-74f2e7c40bf6cb254da2118d311bb570363cf3e7.tar.bz2
gentoo-74f2e7c40bf6cb254da2118d311bb570363cf3e7.zip
dev-python/voluptuous: 0.10.5 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/voluptuous/Manifest1
-rw-r--r--dev-python/voluptuous/voluptuous-0.10.5.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/voluptuous/Manifest b/dev-python/voluptuous/Manifest
index eaecc904d3ab..48f080debd60 100644
--- a/dev-python/voluptuous/Manifest
+++ b/dev-python/voluptuous/Manifest
@@ -1 +1,2 @@
+DIST voluptuous-0.10.5.tar.gz 41436 SHA256 7a7466f8dc3666a292d186d1d871a47bf2120836ccb900d5ba904674957a2396 SHA512 2024121c56a91cc3bf5102ca68f8347461b2041da9a352eade0e0ce3657d9a477a60a7a5823e8f3628eee7b327840b5c4eba13c106ea49ea91a553d6b5edd363 WHIRLPOOL 1c98847ba5331d198ef997a379ebe369931a7a19a4156dafe5b4475501724f888feab26a7cb30e5d1bda6d27c23e9f259933bf121f385f5b400deac273e9f2c0
DIST voluptuous-0.9.3.tar.gz 34097 SHA256 ed5a11fda273754caabb6becd5fe172ee2621cd2c8ff8279433173bb7b0ec568 SHA512 1c82f9fdca1751fb3e5fa1a0c956e40e3c5ba76623a97f38dee7511c4dac430432f8f0469e1b08d6057056905643f98cc5b19c040386eb5c897dec1940c4eb45 WHIRLPOOL 28c93db7c36af86bb92635852a2c4e0fe62a42a0eff30d2d019ca54c4541f27fa13ef611a77da0ba6d8393eaf807911d8abd62a35614c3a7b7837dc3a343c927
diff --git a/dev-python/voluptuous/voluptuous-0.10.5.ebuild b/dev-python/voluptuous/voluptuous-0.10.5.ebuild
new file mode 100644
index 000000000000..23371fd18f24
--- /dev/null
+++ b/dev-python/voluptuous/voluptuous-0.10.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python data validation library."
+HOMEPAGE="https://github.com/alecthomas/voluptuous"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ unset PYTHONPATH
+ nosetests -v || die "Tests failed"
+}