summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-09-09 08:40:47 +0200
committerHans de Graaff <graaff@gentoo.org>2022-09-10 07:42:25 +0200
commit72b5c1fd763aaf81675cfe16aa87b57b6c58c1a5 (patch)
treeabdc3d6b05003fc63fa2c041e57d89ecaaaddead
parentdev-python/numpy: add 1.23.3 (diff)
downloadgentoo-72b5c1fd763aaf81675cfe16aa87b57b6c58c1a5.tar.gz
gentoo-72b5c1fd763aaf81675cfe16aa87b57b6c58c1a5.tar.bz2
gentoo-72b5c1fd763aaf81675cfe16aa87b57b6c58c1a5.zip
dev-ruby/kramdown: drop 2.3.1-r1, 2.3.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/kramdown/Manifest2
-rw-r--r--dev-ruby/kramdown/kramdown-2.3.1-r1.ebuild55
-rw-r--r--dev-ruby/kramdown/kramdown-2.3.2.ebuild55
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index 32f424774d3b..6d06c2bd7b17 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1,3 +1 @@
-DIST kramdown-2.3.1.gem 122368 BLAKE2B 731e20904f238f44db594c7b8efac858187c935d9fbf8a421ddceeb1aa486f0980b502953f8eaa7e3100f7b7722d09b1da35091d28977c70cfd1ef24a080c3e1 SHA512 d1955065e3c5d7a60e595b647d5e453cf07a08fe25d40c67cf6f32d30f704a2c653a52959f8c71b3290e6da74836a085fa6bf8201c878303ad572dee8cc64496
-DIST kramdown-2.3.2.gem 122368 BLAKE2B cfed374793257a152e99a0417997c39de943ae8d31b178715355841248789f3986b1bee455396a5ac8ad2d6784a5fd33e82effb8430230cddec83579cb8ca2d9 SHA512 268b55b45ad2c6dd02776abd5777c7f51ea8724c64b03d8a859bd809b54b181e018fcf5ca38170c89acfac5cef2e6de253f1c6037fe642c6c093e339fd8f4d1b
DIST kramdown-2.4.0.gem 122368 BLAKE2B 86b1232583dc88f8a576fb17e3e2ee756f109700634783815e8ba1f722dd8c872f2f6a978d33e1970814530090665eba3693206e57d3f274bb39655a7ac2d208 SHA512 8e52c5cc53d2f0085e30188aa7bf67f92dfe7f0801297c6a45293cca307e3442baa06443638c1161dad4a4aa332cbc5b4f9b6281ba4c6346122a9fff5a3743c7
diff --git a/dev-ruby/kramdown/kramdown-2.3.1-r1.ebuild b/dev-ruby/kramdown/kramdown-2.3.1-r1.ebuild
deleted file mode 100644
index d41f19d16265..000000000000
--- a/dev-ruby/kramdown/kramdown-2.3.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
-HOMEPAGE="https://kramdown.gettalong.org/"
-
-LICENSE="MIT"
-
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="latex"
-
-LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
-RDEPEND+=" ${LATEX_DEPS}"
-DEPEND+=" test? (
- ${LATEX_DEPS}
- >=app-text/htmltidy-5.0.0
-)"
-
-ruby_add_rdepend "
- dev-ruby/rexml
- >=dev-ruby/rouge-1.8
- >=dev-ruby/stringex-1.5.1
- !!<dev-ruby/kramdown-1.17.0-r2:0"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )
- test? ( >=dev-ruby/minitest-5.0 )"
-
-all_ruby_prepare() {
- if ! use latex; then
- # Remove latex tests. They will fail gracefully when latex isn't
- # present at all, but not when components are missing (most
- # notable ucs.sty).
- sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
- fi
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/man1/kramdown.1
-}
diff --git a/dev-ruby/kramdown/kramdown-2.3.2.ebuild b/dev-ruby/kramdown/kramdown-2.3.2.ebuild
deleted file mode 100644
index d6208fd4678a..000000000000
--- a/dev-ruby/kramdown/kramdown-2.3.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
-HOMEPAGE="https://kramdown.gettalong.org/"
-
-LICENSE="MIT"
-
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~s390 ~sparc ~x86"
-IUSE="latex"
-
-LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
-RDEPEND+=" ${LATEX_DEPS}"
-DEPEND+=" test? (
- ${LATEX_DEPS}
- >=app-text/htmltidy-5.0.0
-)"
-
-ruby_add_rdepend "
- dev-ruby/rexml
- >=dev-ruby/rouge-3.26.0:2
- >=dev-ruby/stringex-1.5.1
- !!<dev-ruby/kramdown-1.17.0-r2:0"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )
- test? ( >=dev-ruby/minitest-5.0 )"
-
-all_ruby_prepare() {
- if ! use latex; then
- # Remove latex tests. They will fail gracefully when latex isn't
- # present at all, but not when components are missing (most
- # notable ucs.sty).
- sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
- fi
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/man1/kramdown.1
-}