summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-15 05:30:44 +0100
committerSam James <sam@gentoo.org>2024-07-15 05:30:44 +0100
commit632c67be19ade509287fbfe48442f97afd899d1d (patch)
tree6d2f7b4d42c7b17aea4fbe983cdc0eebcaedbd46
parentapp-emulation/cloud-init: Stabilize 23.4 x86, #932918 (diff)
downloadgentoo-632c67be19ade509287fbfe48442f97afd899d1d.tar.gz
gentoo-632c67be19ade509287fbfe48442f97afd899d1d.tar.bz2
gentoo-632c67be19ade509287fbfe48442f97afd899d1d.zip
app-emulation/cloud-init: drop 22.2.2, 22.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/cloud-init/Manifest2
-rw-r--r--app-emulation/cloud-init/cloud-init-22.2.2.ebuild95
-rw-r--r--app-emulation/cloud-init/cloud-init-22.4.ebuild95
3 files changed, 0 insertions, 192 deletions
diff --git a/app-emulation/cloud-init/Manifest b/app-emulation/cloud-init/Manifest
index e09f96458f80..cabaa649916e 100644
--- a/app-emulation/cloud-init/Manifest
+++ b/app-emulation/cloud-init/Manifest
@@ -1,4 +1,2 @@
-DIST cloud-init-22.2.2.tar.gz 1349451 BLAKE2B fdb6669e9762984614fefe787834f20f056345d304327679fa8bc7b4d6566509a23ecc4a7ac4e6368b9b9078a72fe6fe35533a67e7aeb0c0accbf5ad014f8aae SHA512 18b75ebbb5e808e19df5ceddb6402cc881c33443fb169f736f54837254ba43836994f2392a26febbd8df3342b3467ee72759b6942cfeb96d07c0e452c11dd0bf
-DIST cloud-init-22.4.tar.gz 1494295 BLAKE2B 5f961c895c0d6c78a7cee47d2b52acd57d959baeb5172cea89d75ffe23424e3a8a3170a0ecdcad729c6cb0c898477ea94c43a5f8bdf200fc3f122c32fdb2e96d SHA512 6151d1d5e4be241219cb5804ca2bad2dd790f366bc847d286a8840faad1fb4adf5d780c9418ce574c2cfcefc16851a49961f33c5da1fbc84bb8299cf138bfcfc
DIST cloud-init-23.4.tar.gz 1648908 BLAKE2B 0acec9c437c7a5a86ed9cd8718830a7311c257ae9f223a68959b8d1eccc693b35f6a716de5c04112d848c1e2e54f6461a3919fd733debba18989145f6669d359 SHA512 34966b173571764bf83779bef0e89a86971310ff0fa62feceef4fbe17c9fa6d1b69f11f57caaa32cc4ae4a74f598f157dfb3ce356221044666401230cfb1ad13
DIST cloud-init-24.2.tar.gz 1786275 BLAKE2B 21f5209a77ef401d12271f6ea695d84065b22f40b7273dd8709dee5fadc7038a0f59a9a3dd53b73812a44a603b5cdc7fb36b71fcdb1f2d4295d87d2cc6069fcd SHA512 72de351b3e978e01a4695b58987d942cc1b2faee749ac0df2024a839e0e1539c9b1f0a9e5cf1930e33c36344d152b7580cfe2dd55f95ad4f669df9b4dda4648d
diff --git a/app-emulation/cloud-init/cloud-init-22.2.2.ebuild b/app-emulation/cloud-init/cloud-init-22.2.2.ebuild
deleted file mode 100644
index a1d0ec08c413..000000000000
--- a/app-emulation/cloud-init/cloud-init-22.2.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Disabled for now: bug #850628
-# https://bugs.launchpad.net/cloud-init/+bug/1978328
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 udev
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
-else
- SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="amd64 arm64 ppc64 x86"
-fi
-
-DESCRIPTION="Cloud instance initialisation magic"
-HOMEPAGE="https://launchpad.net/cloud-init"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/oauthlib[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/netifaces[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- net-analyzer/macchanger
- sys-apps/iproute2
- sys-fs/growpart
- virtual/logger
- selinux? ( sec-policy/selinux-cloudinit )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Fix location of documentation installation
- sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
-
- if [[ ${PV} == *9999 ]] ; then
- sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
-}
-
-python_install_all() {
- keepdir /etc/cloud
-
- distutils-r1_python_install_all
-
- # installs as non-executable
- chmod +x "${D}"/etc/init.d/* || die
-}
-
-pkg_prerm() {
- udev_reload
-}
-
-pkg_postinst() {
- udev_reload
-
- elog "cloud-init-local needs to be run in the boot runlevel because it"
- elog "modifies services in the default runlevel. When a runlevel is started"
- elog "it is cached, so modifications that happen to the current runlevel"
- elog "while you are in it are not acted upon."
-}
diff --git a/app-emulation/cloud-init/cloud-init-22.4.ebuild b/app-emulation/cloud-init/cloud-init-22.4.ebuild
deleted file mode 100644
index 839d6105a832..000000000000
--- a/app-emulation/cloud-init/cloud-init-22.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Disabled for now: bug #850628
-# https://bugs.launchpad.net/cloud-init/+bug/1978328
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 python3_11 )
-
-inherit distutils-r1 udev
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
-else
- SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="amd64 arm64 ppc64 x86"
-fi
-
-DESCRIPTION="Cloud instance initialisation magic"
-HOMEPAGE="https://launchpad.net/cloud-init"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/oauthlib[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/netifaces[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- net-analyzer/macchanger
- sys-apps/iproute2
- sys-fs/growpart
- virtual/logger
- selinux? ( sec-policy/selinux-cloudinit )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Fix location of documentation installation
- sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
-
- if [[ ${PV} == *9999 ]] ; then
- sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
-}
-
-python_install_all() {
- keepdir /etc/cloud
-
- distutils-r1_python_install_all
-
- # installs as non-executable
- chmod +x "${D}"/etc/init.d/* || die
-}
-
-pkg_prerm() {
- udev_reload
-}
-
-pkg_postinst() {
- udev_reload
-
- elog "cloud-init-local needs to be run in the boot runlevel because it"
- elog "modifies services in the default runlevel. When a runlevel is started"
- elog "it is cached, so modifications that happen to the current runlevel"
- elog "while you are in it are not acted upon."
-}