summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-24 07:32:34 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-24 08:16:41 +0100
commit4afbbe303a65bc0532e4de2cdc9f712e8ce06cc2 (patch)
tree1f2f028e100e51c94e02d876770ac8390e700208
parentdev-python/faker: Bump to 35.0.0 (diff)
downloadgentoo-4afbbe303a65bc0532e4de2cdc9f712e8ce06cc2.tar.gz
gentoo-4afbbe303a65bc0532e4de2cdc9f712e8ce06cc2.tar.bz2
gentoo-4afbbe303a65bc0532e4de2cdc9f712e8ce06cc2.zip
dev-python/elasticsearch: Bump to 8.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/elasticsearch/Manifest1
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.17.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index 9806b92f587f..d35204e9ae68 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1 +1,2 @@
DIST elasticsearch-py-8.17.0.gh.tar.gz 1604639 BLAKE2B 94363d23606ec820fbc4608ad8319a2753f04f6a250204ec91662772712079ac56d63ef630780fc19f20e9b0527ceea4db2c3d7c4db98c7e4410d5ce67751a6f SHA512 2239fe52a49387988903d574e33d2f5aedf077beb9c00c46a725af942289f0b0522aef462fb8ee43b078594e4af65b3b14b2fdaefea076ddd1dad8ca0a306843
+DIST elasticsearch-py-8.17.1.gh.tar.gz 1690228 BLAKE2B da442d4a9a469ed5fc5f9035652746a0d5b28e90644d9fd8afb5127bfc00ed15bbe5fde27efff0506d07dc48fdce72cd326eed36d86ba8a596e180e07c2e6b0d SHA512 45312d4ebe90c84c06a8e19d66618f668ad6b8a81b16a89ebf68136a925733a0373321df0726a967d7ede9f30c0e5be6fed1c69056e9ec1156e7cd784341c621
diff --git a/dev-python/elasticsearch/elasticsearch-8.17.1.ebuild b/dev-python/elasticsearch/elasticsearch-8.17.1.ebuild
new file mode 100644
index 000000000000..3be4ed08b0cb
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.17.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py/
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="
+ https://github.com/elastic/elasticsearch-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}]
+ <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8.15.1[${PYTHON_USEDEP}]
+ >=dev-python/orjson-3[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/opentelemetry-api[${PYTHON_USEDEP}]
+ dev-python/opentelemetry-sdk[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pyarrow[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/sphinx \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests
+ # so its an ever moving target. It also requires effort to blacklist
+ # tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even
+ # if all are fixed in this package. Not worth it.
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it
+ # as well.
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+ )
+
+ local -x TEST_WITH_OTEL=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}