summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-17 15:42:06 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-17 21:47:02 +0100
commit458427ffead8cf9ea3e42f60db3dfa0a508654f3 (patch)
treede680ff98231dcfc8824da0819aeb5461e5c76a1
parentdev-python/pykka: Bump to 4.2.0 (diff)
downloadgentoo-458427ffead8cf9ea3e42f60db3dfa0a508654f3.tar.gz
gentoo-458427ffead8cf9ea3e42f60db3dfa0a508654f3.tar.bz2
gentoo-458427ffead8cf9ea3e42f60db3dfa0a508654f3.zip
dev-python/typeguard: Bump to 4.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/typeguard/Manifest1
-rw-r--r--dev-python/typeguard/typeguard-4.4.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/typeguard/Manifest b/dev-python/typeguard/Manifest
index 8e0d96e110b4..4ccdd610fa7d 100644
--- a/dev-python/typeguard/Manifest
+++ b/dev-python/typeguard/Manifest
@@ -1 +1,2 @@
DIST typeguard-4.4.1.tar.gz 74959 BLAKE2B 1b08e7404045d128bbecf5c16c0b24dbc42a59a3e78d0516f458989d6874d7795332017ac87ce59a7ed05edf4df6b918516d63d90723c702b5d05d7acc0193df SHA512 af862371b22237cc39efad4840bb0bbd632116bee6e095531426dbaff606b6c1b2b58c82ddc083f816c340b4151421ff911ffd689dc3dc2fb7a031c067182aba
+DIST typeguard-4.4.2.tar.gz 75746 BLAKE2B f2a2c318a27eea573ce358284aedb97e126ce1aa7f60755079c07eddb1c93785ee6a50f5e95cf47234534cd44541efa974fc1ebe7af737875a328870235ca285 SHA512 205429ae4960563c10b747956a2f4f41504abb300957cc75be0e9a6caecba84bebbbbf2e71d22f2961870f12f29e03fcd78ef0cd54edd7285f62ceaf35a74138
diff --git a/dev-python/typeguard/typeguard-4.4.2.ebuild b/dev-python/typeguard/typeguard-4.4.2.ebuild
new file mode 100644
index 000000000000..930160ec4ebf
--- /dev/null
+++ b/dev-python/typeguard/typeguard-4.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run-time type checker for Python"
+HOMEPAGE="
+ https://pypi.org/project/typeguard/
+ https://github.com/agronholm/typeguard/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # mypy changes results from version to version
+ tests/mypy
+ )
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # the XFAIL test pass due to some package being installed
+ epytest -o xfail_strict=False -p typeguard
+}