summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-29 09:29:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-29 10:00:11 +0100
commit418933ddfe504c102f16b3cb90d69f7b16cecd14 (patch)
treee8710a41e7bc6c9139613f1cc591aa9f232c5117
parentdev-python/aiosmtpd: Bump to 1.2.4 (diff)
downloadgentoo-418933ddfe504c102f16b3cb90d69f7b16cecd14.tar.gz
gentoo-418933ddfe504c102f16b3cb90d69f7b16cecd14.tar.bz2
gentoo-418933ddfe504c102f16b3cb90d69f7b16cecd14.zip
dev-python/jaraco-context: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-context/Manifest1
-rw-r--r--dev-python/jaraco-context/jaraco-context-4.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jaraco-context/Manifest b/dev-python/jaraco-context/Manifest
index 521629f10e57..3e3330b30174 100644
--- a/dev-python/jaraco-context/Manifest
+++ b/dev-python/jaraco-context/Manifest
@@ -1 +1,2 @@
DIST jaraco.context-3.0.0.tar.gz 12901 BLAKE2B b0a18d8799de211c9827a708302798372dff06767fbac08f4bff8ed48e1dde4cca8d3896a3c4dccd186efdc4d80ffe2b972a05e8f351ec53dcd0c7dec45cfcea SHA512 fd48a9af65edea3212c194758ba1a8fc2d7efc35f7eaec959a7f327ad46d1bf15f295af29d62726f813d35baaeaff35bc3fcd6e27a0e0f272232772e1cb87c17
+DIST jaraco.context-4.0.0.tar.gz 11257 BLAKE2B 38faeb6036ebd2fc6cea9f29dc7fbd89b0ea60819e280e36c8c4f0f90e9ba2552524bfc0f3fc16601cd43276d19e166d9de4107ced885f88dea11efbe0a79913 SHA512 ec76e03d3d5a2148dd49159b303ee278501b9744d3e4d096d6aca516658fb04da020d1cbb1c8eb3dcb58097266e0419883d23e4064c295ced3846540177e57ee
diff --git a/dev-python/jaraco-context/jaraco-context-4.0.0.ebuild b/dev-python/jaraco-context/jaraco-context-4.0.0.ebuild
new file mode 100644
index 000000000000..a854993fe130
--- /dev/null
+++ b/dev-python/jaraco-context/jaraco-context-4.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Context managers by jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.context"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest