summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-03-19 13:26:05 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-03-19 15:06:38 +0200
commit34cd33e0de6c3278bb1dd5a3ba5bbc93847262c8 (patch)
treeafc374a46b28745aeb675f55d4c8a29b5ded85f4
parentdev-qt/qtwayland: add 6.4.3 (diff)
downloadgentoo-34cd33e0de6c3278bb1dd5a3ba5bbc93847262c8.tar.gz
gentoo-34cd33e0de6c3278bb1dd5a3ba5bbc93847262c8.tar.bz2
gentoo-34cd33e0de6c3278bb1dd5a3ba5bbc93847262c8.zip
dev-qt/qt5compat: add 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-qt/qt5compat/Manifest1
-rw-r--r--dev-qt/qt5compat/qt5compat-6.4.3.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-qt/qt5compat/Manifest b/dev-qt/qt5compat/Manifest
index c717766a6504..6b72b7cfd09a 100644
--- a/dev-qt/qt5compat/Manifest
+++ b/dev-qt/qt5compat/Manifest
@@ -1 +1,2 @@
DIST qt5compat-everywhere-src-6.4.2.tar.xz 14638200 BLAKE2B 518d254012f65e2f73dbef362abaf5e2890f6b8a97a0e6211b65a92e2e64d149b0fafd39a7f7a9d2f87a6deda04286a0eb2ced56810fb894d5305da5a81f5edf SHA512 8aa49cbbe92e628be3b502bbf0a9668b7664829a12c8cf0eced816cda880d034d567f287d2a1bd1efb7d693b3de7e583d2c2d69e2437cdeda737c67d7949ca56
+DIST qt5compat-everywhere-src-6.4.3.tar.xz 14638428 BLAKE2B 70afd4ff347fc58a4b67ce15d7ccaa542084eeeda672c5f33feedd550cb21a7d93bab192b24ab9b8330aad2a9cfee9f9b47f908cde5667a444f44e0882ceab60 SHA512 22e3d6360afdb83b4bd122153cf3bba09d8593dbdd65ccf5b80e032b9de437f868b05c7170e636fd6bd8f42dd1eb56b07f21b73fd0c4a5437fcb72aa070d830b
diff --git a/dev-qt/qt5compat/qt5compat-6.4.3.ebuild b/dev-qt/qt5compat/qt5compat-6.4.3.ebuild
new file mode 100644
index 000000000000..e930872d0c3d
--- /dev/null
+++ b/dev-qt/qt5compat/qt5compat-6.4.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module containing the unsupported Qt 5 APIs"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui,network]
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"