summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-22 04:12:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-22 04:49:32 +0200
commit2d2b361e66761333d82df1786e3f96b403ceeb06 (patch)
treefef67ddbb88894b3f29a02026ea61845c6d5766f
parentdev-python/networkx: Bump to 3.4.2 (diff)
downloadgentoo-2d2b361e66761333d82df1786e3f96b403ceeb06.tar.gz
gentoo-2d2b361e66761333d82df1786e3f96b403ceeb06.tar.bz2
gentoo-2d2b361e66761333d82df1786e3f96b403ceeb06.zip
dev-python/sqlglot: Bump to 25.26.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-25.26.0.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 63e6c3b03e9d..315670406645 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -22,6 +22,7 @@ DIST smallvec-1.11.2.crate 34801 BLAKE2B 58645e99db8f02db64d02c75860c7ea41836c42
DIST sqlglot-25.24.5.tar.gz 19507940 BLAKE2B ad13b5b90adeefe5edc9338ce06c659b3f401022f04561f78efeca2d0bf78c60f86922f99af493104412574701e2a7172040a7f924c6c6a401487d462e8af1a9 SHA512 3ceab4bce81cbfd463054d1e02e9943bc33176de73a4ac48a01a28ee2d049beb2eebf8e496036c492c719ffa54325bcde5a80a809a264f6d8711f8af6a6b4774
DIST sqlglot-25.25.0.tar.gz 19525504 BLAKE2B 30336cc1ed055ffa12301e93fd67d212679e2e5e0313316022111a7aecb016558d6e69fa26dc105b1eeefdd3abd50dc6f236aad843d5f43d89880e8e7e9c2301 SHA512 e1ee935b82553a3b0dc3a91de4cb0dab720494d2fbaeae50bd1e1208a5f2bafa2a5136ea0bc885e02770ddc21239ce1864c7a660b52a5b396af9af5d7c2704d7
DIST sqlglot-25.25.1.tar.gz 19539259 BLAKE2B 92dc212b4f7f961bda9a95dcc1c1be589fe8cb56612213325f2db6df2a8dc00a8c7fa775fe0685c1b27421d4c4c540e97f18f57c56d57f1ef9aa2a434f8d8e5e SHA512 025012a7d323c6c7ff9baf260ae83522556a8efa9b120b4cc135f74261bb6874b8da4f7cc063f5f5b601443e1d19024fa225c954e1566e638607640fb4cce9c8
+DIST sqlglot-25.26.0.tar.gz 19542750 BLAKE2B 5e8eda29d26e7566bb39eb8636ee502d04103dbcd088a07ba4e425adf7ffcce78cc6a187b5dbd19c731c39443cffb5f8bd9dba6f2c9169b1bb10f1719fc3e8c1 SHA512 41fa2f3dd181354380036aba637bdf15ead40d1c3767caa4958a83c65483e90149e62fe04976318dcfcda7c68d554affef077d82e7ac754a9e94f593eae68614
DIST syn-2.0.41.crate 246016 BLAKE2B 9d389f2e2a0acb4c84c309456e8ffcc88c5d4d541535ed136832d7a6054dde45a598bb68e8a6f3062ca2a96e1ceae947d54b3aec9bad65b0c51d6733aa6c80db SHA512 6bbaf69ca783025dfb81ac3612ac60bfbed31b2d87792909b35c12892dadebdaff2ddf9463105e536b671dce5870610ab90fe29471284bbd3014dca8d6993f1a
DIST target-lexicon-0.12.12.crate 25156 BLAKE2B f3803596c75f6c89438592a1176c3748fc2c0524d7d50a20056de1cd26d40c572b05bafcdf6dd702752864bea37c8b4f28f96dadc12a5b3bb1d279b25e489f85 SHA512 6147295c43ba1b7b087a3c5ab51534b2985e4e77e5e15687978cfb9d07e21c4fd9bc7191576d6cabd268d08a44dc733c4a957e59dba8b948c2055d8bb433aeca
DIST unicode-ident-1.0.12.crate 42168 BLAKE2B 4cede03c08758ccd6bf53a0d0057d7542dfdd0c93d342e89f3b90460be85518a9fd24958d8b1da2b5a09b5ddbee8a4263982194158e171c2bba3e394d88d6dac SHA512 bc1824e1e4452a40732fc69874d7e1a66f7803717a314790dcf48867eba34bc9441331ef031e386912e52c385645c25b6ed39d4f149973b5b97371b1b96b1920
diff --git a/dev-python/sqlglot/sqlglot-25.26.0.ebuild b/dev-python/sqlglot/sqlglot-25.26.0.ebuild
new file mode 100644
index 000000000000..456b6e98cfce
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-25.26.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+CARGO_OPTIONAL=1
+CRATES="
+ autocfg@1.1.0
+ bitflags@1.3.2
+ cfg-if@1.0.0
+ heck@0.4.1
+ indoc@2.0.4
+ libc@0.2.150
+ lock_api@0.4.11
+ memoffset@0.9.0
+ once_cell@1.19.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.9
+ proc-macro2@1.0.70
+ pyo3-build-config@0.20.0
+ pyo3-ffi@0.20.0
+ pyo3-macros-backend@0.20.0
+ pyo3-macros@0.20.0
+ pyo3@0.20.0
+ quote@1.0.33
+ redox_syscall@0.4.1
+ scopeguard@1.2.0
+ smallvec@1.11.2
+ syn@2.0.41
+ target-lexicon@0.12.12
+ unicode-ident@1.0.12
+ unindent@0.2.3
+ windows-targets@0.48.5
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_msvc@0.48.5
+ windows_i686_gnu@0.48.5
+ windows_i686_msvc@0.48.5
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_msvc@0.48.5
+"
+
+inherit cargo distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+SRC_URI+="
+ native-extensions? (
+ ${CARGO_CRATE_URIS}
+ )
+"
+
+LICENSE="MIT"
+LICENSE+=" native-extensions? ("
+# Dependent crate licenses
+LICENSE+=" Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016"
+LICENSE+=" )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ native-extensions? (
+ ${RUST_DEPEND}
+ dev-util/maturin[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/sqlglotrs/sqlglotrs.*.so"
+
+src_unpack() {
+ cargo_src_unpack
+}
+
+src_prepare() {
+ # remove fragile timing check
+ sed -i -e '/assertLessEqual(time\.time/d' tests/test_parser.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use native-extensions; then
+ local DISTUTILS_USE_PEP517=maturin
+ cd sqlglotrs || die
+ distutils-r1_python_compile
+ cd - >/dev/null || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # timing, sigh
+ # https://github.com/tobymao/sqlglot/issues/3961
+ tests/test_generator.py::TestGenerator::test_generate_nested_binary
+ )
+ local EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+ )
+
+ # make sure not to use an earlier installed version
+ local -x SQLGLOTRS_TOKENIZER=$(usex native-extensions 1 0)
+ rm -rf sqlglotrs || die
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}