summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 14:26:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:04:50 +0100
commit260e2c7afada56c78b2757eb265c187eb55bab50 (patch)
tree312f0d92e9c71492998d7ca8d07ac789261ff7a5
parentdev-python/networkx: Bump to 3.0 (diff)
downloadgentoo-260e2c7afada56c78b2757eb265c187eb55bab50.tar.gz
gentoo-260e2c7afada56c78b2757eb265c187eb55bab50.tar.bz2
gentoo-260e2c7afada56c78b2757eb265c187eb55bab50.zip
dev-python/coverage: Bump to 7.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-7.0.4.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 7f4afab10793..3d4cd930f330 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -3,3 +3,4 @@ DIST coverage-7.0.0.tar.gz 780514 BLAKE2B 2d7e0190bacd5ef6db35e3c6ab5114571ce394
DIST coverage-7.0.1.tar.gz 781226 BLAKE2B 52da1dd6f3eae7d235a597d3dd24d4042ee1ee4c082d5700d04065b8328af01ef006121a3588f04e79235c559e6dc6d2f5168b5079037e19a41e1b8e869825a0 SHA512 63ec6a21d4af73720a2b79309cb1d0e61bbe67e04835bd907f19e482c1479cbb69d353cd42be0d4d9e75cb4082debb464ec5e9acf270c86042e7db58de1d024d
DIST coverage-7.0.2.tar.gz 789237 BLAKE2B 6a83b6736374679e855eefc99488eea8f4fa8b785bbff6455c6087a03b3d074d200b219fb7f9eaaa08824b9b37363861d02f0ca0cd157adf285b1e2e7bec92a2 SHA512 d2981951517ac1efe08df4f19931dd581fc1877d7095003ae1b0c63e10b388238bc793823471c5ac3243f6b46e9284057f3e569a14dc972dcaf342768da9d73e
DIST coverage-7.0.3.tar.gz 790351 BLAKE2B 0e0e2e0dfd6773bf78318b63400c6ba15b8218590d9d2c99666a2d6bb41745aa7d00b7c32879eabf9c0f6a2e3831637970fd8ea308a50befd526f2e0aafb6867 SHA512 6a298aa7fdf460277e85174fe930bf4dcdabfa57b753adda2d4b8381cd61c2e22700d287fefa16f098de318e6d79849c4db85a6d9f6e069f0acd5ce6ac93f154
+DIST coverage-7.0.4.tar.gz 794474 BLAKE2B 4c3e2e53a3a5bd55d2ba8c409a1983e96ca7ace33d69052f4e44c27d53e3732513a35c7e3e553fceffe06d5c9d664f548ce59ca171b210dafc88e6a7eb657d3b SHA512 f3f895af4d91a796b8ebc360ad116b78acf71a0f55cc1439a203440241e896f6666d9eccdb69f2cfb8162275755137356cb8b1df6504faa51f0a026d694abceb
diff --git a/dev-python/coverage/coverage-7.0.4.ebuild b/dev-python/coverage/coverage-7.0.4.ebuild
new file mode 100644
index 000000000000..ed343a56f333
--- /dev/null
+++ b/dev-python/coverage/coverage-7.0.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}