summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-11 21:36:41 +0300
committerMichał Górny <mgorny@gentoo.org>2024-08-17 21:16:20 +0200
commit24e7c2248db29dbfd2806f212b218df14c0f9152 (patch)
treeb2935fe89c5f728ceb01e996f654f26e2028320f
parentmedia-video/mkvtoolnix: drop 81.0 (diff)
downloadgentoo-24e7c2248db29dbfd2806f212b218df14c0f9152.tar.gz
gentoo-24e7c2248db29dbfd2806f212b218df14c0f9152.tar.bz2
gentoo-24e7c2248db29dbfd2806f212b218df14c0f9152.zip
net-libs/enet: add 1.3.18
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-libs/enet/Manifest1
-rw-r--r--net-libs/enet/enet-1.3.18.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/enet/Manifest b/net-libs/enet/Manifest
index be5c90a2a709..814d3eb27a43 100644
--- a/net-libs/enet/Manifest
+++ b/net-libs/enet/Manifest
@@ -1 +1,2 @@
DIST enet-1.3.17.tar.gz 703278 BLAKE2B d31838a173f629a2216f59173c259cf7cb35985913c5f8f016641ceb189dc20308effa206f03391cafde842ad6e43ec1776d38ce02283bd5990ccf38eadf4d6b SHA512 efa0cb093a6ca295e5012a4fdebc5ffd6516a66a967e97b386b72781b18ce4a118c9bf94e87adbbdcd0ed441e22c62a05c24ff39fd6b475919e8efe9ab4715e4
+DIST enet-1.3.18.tar.gz 737164 BLAKE2B 13a4543d11d7b4c727badac2293b28e1fe465e6990b59139ec2af6d43f827aa83e243fe35aa789b22498898faa8091b26c8bbc38165ef2c5980d775e48d93bcc SHA512 d39b3bc78274ed4040580a0b13f7e628829d88993aa1bae15ab02afe64598badb2c6863b128f25234e27c3a8c4bcfbda360b3b237c92388675714549e9757bb5
diff --git a/net-libs/enet/enet-1.3.18.ebuild b/net-libs/enet/enet-1.3.18.ebuild
new file mode 100644
index 000000000000..3ea586ef1690
--- /dev/null
+++ b/net-libs/enet/enet-1.3.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/ https://github.com/lsalzman/enet/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3/8"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}