summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-25 04:12:17 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-25 04:12:44 +0200
commit0acb9e257add056f0666ca187cb7d2dd36835558 (patch)
tree4c2d598b81e83f513c1519b08049c297074d0822
parentsys-fs/s3ql: version bump to 2.20 (diff)
downloadgentoo-0acb9e257add056f0666ca187cb7d2dd36835558.tar.gz
gentoo-0acb9e257add056f0666ca187cb7d2dd36835558.tar.bz2
gentoo-0acb9e257add056f0666ca187cb7d2dd36835558.zip
sys-devel/llvm: Restore gtest patch for <9999, #592046
-rw-r--r--sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch30
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.1-r2.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.1.ebuild2
5 files changed, 34 insertions, 4 deletions
diff --git a/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch b/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch
new file mode 100644
index 000000000000..a24977c03140
--- /dev/null
+++ b/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch
@@ -0,0 +1,30 @@
+From 1303993b5b9a4195ebe4930a8cd345c875e7f25c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 9 Jun 2015 11:58:52 +0200
+Subject: [PATCH 05/10] cmake: Do not install libgtest
+
+libgtest is an internal test dependency, and should not be installed to
+the live system as a part of LLVM.
+
+Bug: http://llvm.org/bugs/show_bug.cgi?id=18341
+---
+ utils/unittest/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/utils/unittest/CMakeLists.txt b/utils/unittest/CMakeLists.txt
+index c9a2cdd..bb4f667 100644
+--- a/utils/unittest/CMakeLists.txt
++++ b/utils/unittest/CMakeLists.txt
+@@ -37,6 +37,9 @@ if (PTHREAD_LIBRARY_PATH)
+ list(APPEND LIBS pthread)
+ endif()
+
++# Delay building until the tests pull it in, and avoid installing it
++set(EXCLUDE_FROM_ALL ON)
++
+ add_llvm_library(gtest
+ googletest/src/gtest-all.cc
+
+--
+2.9.3
+
diff --git a/sys-devel/llvm/llvm-3.7.1-r3.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index 02635d1e52d0..353bbff39151 100644
--- a/sys-devel/llvm/llvm-3.7.1-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -155,7 +155,7 @@ src_prepare() {
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- eapply "${FILESDIR}"/9999/0005-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/3.8.1/0005-cmake-Do-not-install-libgtest.patch
# Fix llvm-config for shared linking, sane flags and return values
# in order:
diff --git a/sys-devel/llvm/llvm-3.8.0-r3.ebuild b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
index 7bd13a8a87cf..1f865eab1ad9 100644
--- a/sys-devel/llvm/llvm-3.8.0-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
@@ -156,7 +156,7 @@ src_prepare() {
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- eapply "${FILESDIR}"/9999/0005-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/3.8.1/0005-cmake-Do-not-install-libgtest.patch
# Allow custom cmake build types (like 'Gentoo')
eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch
diff --git a/sys-devel/llvm/llvm-3.8.1-r2.ebuild b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
index 7f096fcfe21a..cbead1dacfe4 100644
--- a/sys-devel/llvm/llvm-3.8.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
@@ -157,7 +157,7 @@ src_prepare() {
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- eapply "${FILESDIR}"/9999/0005-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/3.8.1/0005-cmake-Do-not-install-libgtest.patch
# Allow custom cmake build types (like 'Gentoo')
eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch
diff --git a/sys-devel/llvm/llvm-3.8.1.ebuild b/sys-devel/llvm/llvm-3.8.1.ebuild
index 22ae082f028f..e1050f201c0a 100644
--- a/sys-devel/llvm/llvm-3.8.1.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1.ebuild
@@ -156,7 +156,7 @@ src_prepare() {
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- eapply "${FILESDIR}"/9999/0005-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/3.8.1/0005-cmake-Do-not-install-libgtest.patch
# Allow custom cmake build types (like 'Gentoo')
eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch