summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-07-18 14:55:27 +0200
committerUlrich Müller <ulm@gentoo.org>2015-07-18 14:55:27 +0200
commit6fde345682f37f71f17528a6a721bb6f4bbb9aa9 (patch)
treebf8abde77148e91a869b3591e454cd235d84f974 /net-print
parentVersion bump. (diff)
downloadulm-6fde345682f37f71f17528a6a721bb6f4bbb9aa9.tar.gz
ulm-6fde345682f37f71f17528a6a721bb6f4bbb9aa9.tar.bz2
ulm-6fde345682f37f71f17528a6a721bb6f4bbb9aa9.zip
Initial import. Ebuild contributed by me.
Package-Manager: portage-2.2.20
Diffstat (limited to 'net-print')
-rw-r--r--net-print/brother-mfcj870dw/ChangeLog10
-rw-r--r--net-print/brother-mfcj870dw/Manifest2
-rw-r--r--net-print/brother-mfcj870dw/brother-mfcj870dw-20130812.ebuild60
-rw-r--r--net-print/brother-mfcj870dw/metadata.xml10
4 files changed, 82 insertions, 0 deletions
diff --git a/net-print/brother-mfcj870dw/ChangeLog b/net-print/brother-mfcj870dw/ChangeLog
new file mode 100644
index 0000000..8c9261d
--- /dev/null
+++ b/net-print/brother-mfcj870dw/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-print/brother-mfcj870dw
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*brother-mfcj870dw-20130812 (18 Jul 2015)
+
+ 18 Jul 2015; Ulrich Müller <ulm@gentoo.org>
+ +brother-mfcj870dw-20130812.ebuild, +metadata.xml:
+ Initial import. Ebuild contributed by me.
+
diff --git a/net-print/brother-mfcj870dw/Manifest b/net-print/brother-mfcj870dw/Manifest
new file mode 100644
index 0000000..c0a560d
--- /dev/null
+++ b/net-print/brother-mfcj870dw/Manifest
@@ -0,0 +1,2 @@
+DIST mfcj870dwcupswrapper-3.0.0-1.i386.rpm 17407 SHA256 ee97c1ad72ecd510a9f12024ed85b738dd71a06e36e5083466411e48046f7ce0 SHA512 4999b2862ffcbfe0bc42bf88c1fb6889d9fb719a22b43fb8110a3ab561a3e4c8a768d50d02ecab2f7868f917aeed974f281a6554a74e24a33f4c279e401d33b9 WHIRLPOOL 4fd9905842625bca75c7edc1d5d2a78881143a966e80c77652b23553db889830c298e3111637de379faf4febb018fda0fc2d1e46f5500a2220152136efd6250e
+DIST mfcj870dwlpr-3.0.0-1.i386.rpm 2721307 SHA256 70e8c16f1aea8a47bbbcca3dbc8230b6982f2d8565d515b8344eca065c9b7d30 SHA512 a21b1a54b8c257036117114e6732a84467eae55f4fb019fb035c6ddb8736b4874d0dadba144bb5010cc4a045cab1d74517f51d8b8e4f918c19448f15b957ed6c WHIRLPOOL a85cb366878f30d7ed7ccd944118af0ac6387f6691748b0dbed4116c1b8f1bfb253535134c2936bdede0f0c9e1cf654e23fb0bccf46d6f98e0518ed90d89621c
diff --git a/net-print/brother-mfcj870dw/brother-mfcj870dw-20130812.ebuild b/net-print/brother-mfcj870dw/brother-mfcj870dw-20130812.ebuild
new file mode 100644
index 0000000..16e7764
--- /dev/null
+++ b/net-print/brother-mfcj870dw/brother-mfcj870dw-20130812.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit rpm
+
+MODEL="${PN#*-}"
+PV_LPR="3.0.0-1"
+PV_CUPSWRAPPER="3.0.0-1"
+
+DESCRIPTION="Brother printer driver for MFC-J870DW"
+HOMEPAGE="http://www.brother.com/"
+SRC_URI="http://download.brother.com/welcome/dlf006854/${MODEL}lpr-${PV_LPR}.i386.rpm http://download.brother.com/welcome/dlf006856/${MODEL}cupswrapper-${PV_CUPSWRAPPER}.i386.rpm"
+
+LICENSE="GPL-2+ Brother-lpr no-source-code"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="metric"
+RESTRICT="strip"
+
+RDEPEND="net-print/cups"
+
+S="${WORKDIR}/opt/brother/Printers/${MODEL}"
+
+src_prepare() {
+ if use metric; then
+ sed -i "/^PaperType/s/Letter/A4/" inf/br${MODEL}rc || die
+ fi
+}
+
+src_install() {
+ local dest=/opt/brother/Printers/${MODEL}
+
+ cd "${S}"/lpd || die
+ exeinto ${dest}/lpd
+ doexe br${MODEL}filter filter${MODEL} psconvertij2
+ dosym ${dest}/lpd/filter${MODEL} \
+ /usr/libexec/cups/filter/brother_lpdwrapper_${MODEL}
+
+ cd "${S}"/inf || die
+ insinto ${dest}/inf
+ doins br${MODEL}func ImagingArea PaperDimension paperinfij2
+ doins -r lut
+ insinto /etc${dest}/inf
+ doins br${MODEL}rc # config file
+ dosym /etc${dest}/inf/br${MODEL}rc ${dest}/inf/br${MODEL}rc
+
+ cd "${S}"/cupswrapper || die
+ insinto ${dest}/cupswrapper
+ doins brother_${MODEL}_printer_en.ppd
+ dosym ${dest}/cupswrapper/brother_${MODEL}_printer_en.ppd \
+ /usr/share/cups/model/brother_${MODEL}_printer_en.ppd
+
+ # The brprintconf utility is very broken and mangles the path
+ # of the function list file. Therefore, don't install it.
+ #exeinto ${dest}/bin
+ #doexe "${WORKDIR}"/usr/bin/brprintconf_${MODEL}
+}
diff --git a/net-print/brother-mfcj870dw/metadata.xml b/net-print/brother-mfcj870dw/metadata.xml
new file mode 100644
index 0000000..3b7ffd9
--- /dev/null
+++ b/net-print/brother-mfcj870dw/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='metric'>Default to A4 paper size</flag>
+</use>
+</pkgmetadata>