summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-binpkg/pypy3/pypy3-2.4.0.ebuild')
-rw-r--r--dev-binpkg/pypy3/pypy3-2.4.0.ebuild188
1 files changed, 0 insertions, 188 deletions
diff --git a/dev-binpkg/pypy3/pypy3-2.4.0.ebuild b/dev-binpkg/pypy3/pypy3-2.4.0.ebuild
deleted file mode 100644
index 89a1389..0000000
--- a/dev-binpkg/pypy3/pypy3-2.4.0.ebuild
+++ /dev/null
@@ -1,188 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# pypy3 needs to be built using python 2
-PYTHON_COMPAT=( python2_7 pypy )
-inherit check-reqs eutils multilib multiprocessing pax-utils \
- python-any-r1 toolchain-funcs versionator
-
-DESCRIPTION="A fast, compliant alternative implementation of Python 3"
-HOMEPAGE="http://pypy.org/"
-SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${P}-src.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0/$(get_version_component_range 1-2 ${PV})"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 +jit low-memory ncurses sandbox shadowstack cpu_flags_x86_sse2"
-
-DEPEND=">=sys-libs/zlib-1.1.3
- virtual/libffi
- virtual/libintl
- dev-libs/expat
- dev-libs/openssl
- bzip2? ( app-arch/bzip2 )
- ncurses? ( sys-libs/ncurses[-tinfo] )
- app-arch/lzip
- low-memory? ( virtual/pypy:0 )
- !low-memory? ( ${PYTHON_DEPS} )"
-
-S="${WORKDIR}/${P}-src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if use low-memory; then
- CHECKREQS_MEMORY="1750M"
- use amd64 && CHECKREQS_MEMORY="3500M"
- else
- CHECKREQS_MEMORY="3G"
- use amd64 && CHECKREQS_MEMORY="6G"
- fi
- fi
-
- check-reqs_pkg_pretend
-}
-
-pkg_setup() {
- local force_pypy
-
- pkg_pretend
-
- use low-memory && local EPYTHON
- if has_version virtual/pypy && [[ ! ${EPYTHON} ]]; then
- einfo "Using PyPy to perform the translation."
- local EPYTHON=pypy
- else
- einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please install"
- einfo "virtual/pypy and ensure that EPYTHON variable is unset."
- fi
-
- python-any-r1_pkg_setup
-
- local cpu
- if use amd64; then
- # common denominator between Intel & AMD
- cpu='x86-64'
- elif use x86; then
- if use cpu_flags_x86_sse2; then
- # lowest with SSE2
- cpu='pentium-m'
- else
- # lowest with SSE, compat. with athlon-xp
- # TODO: do we want to support something older?
- cpu='pentium3'
- fi
- else
- die "Unsupported arch ${ARCH}"
- fi
-
- export CFLAGS="-march=${cpu} -mtune=generic -O2 -pipe"
- export CXXFLAGS=${CFLAGS}
-
- elog "CFLAGS: ${CFLAGS}"
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc-4.9.patch \
- "${FILESDIR}"/2.3.1-shared-lib.patch # 517002
- epatch "${FILESDIR}"/${PN}-2.4.0-libressl.patch
-
- epatch_user
-}
-
-src_compile() {
- tc-export CC
-
- local jit_backend
- if use jit; then
- jit_backend='--jit-backend='
-
- # We only need the explicit sse2 switch for x86.
- # On other arches we can rely on autodetection which uses
- # compiler macros. Plus, --jit-backend= doesn't accept all
- # the modern values...
-
- if use x86; then
- if use cpu_flags_x86_sse2; then
- jit_backend+=x86
- else
- jit_backend+=x86-without-sse2
- fi
- else
- jit_backend+=auto
- fi
- fi
-
- local args=(
- --shared
- $(usex jit -Ojit -O2)
- $(usex shadowstack --gcrootfinder=shadowstack '')
- $(usex sandbox --sandbox '')
-
- ${jit_backend}
- --make-jobs=$(makeopts_jobs)
-
- pypy/goal/targetpypystandalone
- )
-
- # Avoid linking against libraries disabled by use flags
- local opts=(
- bzip2:bz2
- ncurses:_minimal_curses
- )
-
- local opt
- for opt in "${opts[@]}"; do
- local flag=${opt%:*}
- local mod=${opt#*:}
-
- args+=(
- $(usex ${flag} --withmod --withoutmod)-${mod}
- )
- done
-
- local interp=( "${PYTHON}" )
- if use low-memory; then
- interp=( env PYPY_GC_MAX_DELTA=200MB
- "${PYTHON}" --jit loop_longevity=300 )
- fi
-
- set -- "${interp[@]}" rpython/bin/rpython --batch "${args[@]}"
- echo -e "\033[1m${@}\033[0m"
- "${@}" || die "compile error"
-
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
-}
-
-src_install() {
- local flags=( bzip2 jit ncurses sandbox shadowstack )
- use x86 && flags+=( cpu_flags_x86_sse2 )
- local f suffix="-${ARCH}"
-
- for f in ${flags[@]}; do
- use ${f} && suffix+="+${f#cpu_flags_x86_}"
- done
-
- local BIN_P=pypy3-bin-${PV}
-
- einfo "Zipping PyPy ..."
- mkdir "${BIN_P}${suffix}"{,/include} || die
- mv pypy-c libpypy-c.so "${BIN_P}${suffix}"/ || die
- mv include/pypy_* "${BIN_P}${suffix}"/include/ || die
- chmod +x "${BIN_P}${suffix}"/pypy-c || die
-
- tar -cf "${BIN_P}${suffix}.tar" "${BIN_P}${suffix}" || die
- lzip -v9 "${BIN_P}${suffix}.tar" || die
-}
-
-# Yup, very hacky.
-pkg_preinst() {
- # integrity check.
- [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
- mkdir -p "${ROOT%/}${PYPY_BINPKG_STORE}" || die
- mv "${S}"/*.tar.lz "${ROOT%/}${PYPY_BINPKG_STORE}" || die
-}