summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phpspec-prophecy')
-rw-r--r--dev-php/phpspec-prophecy/Manifest1
-rw-r--r--dev-php/phpspec-prophecy/files/autoload.php15
-rw-r--r--dev-php/phpspec-prophecy/metadata.xml11
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.8.0.ebuild37
4 files changed, 0 insertions, 64 deletions
diff --git a/dev-php/phpspec-prophecy/Manifest b/dev-php/phpspec-prophecy/Manifest
deleted file mode 100644
index 3c62427..0000000
--- a/dev-php/phpspec-prophecy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST phpspec-prophecy-1.8.0.tar.gz 37907 BLAKE2B 4bdd55d7fc14604c9fade23c60bf51f4c03accc182d7c5ad445dc6212a1e41b1bf392fe8f4a29768ecfcb2af479c0db3e29d5787d12e1f3222b032ba7e64dbc8 SHA512 992673f7cd148cf0b8752bbad614bbe34175a761cd4bf8849625794b505342d1bd918212a0f1463d94513f9e805d3dd127ba129d6622bcda29ea2b5c57a5582f
diff --git a/dev-php/phpspec-prophecy/files/autoload.php b/dev-php/phpspec-prophecy/files/autoload.php
deleted file mode 100644
index eb61ccb..0000000
--- a/dev-php/phpspec-prophecy/files/autoload.php
+++ /dev/null
@@ -1,15 +0,0 @@
-<?php
-/* Autoloader for dev-php/phpspec-prophecy */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-Fedora\Autoloader\Autoload::addPsr0('Prophecy\\', __DIR__);
-
-\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/phpDocumentor/ReflectionDocBlock/autoload.php',
- '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
- '/usr/share/php/Doctrine/Instantiator/autoload.php',
- '/usr/share/php/SebastianBergmann/RecursionContext/autoload.php',
-));
diff --git a/dev-php/phpspec-prophecy/metadata.xml b/dev-php/phpspec-prophecy/metadata.xml
deleted file mode 100644
index d8cce3e..0000000
--- a/dev-php/phpspec-prophecy/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
- <upstream>
- <remote-id type="github">phpspec/prophecy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.8.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.8.0.ebuild
deleted file mode 100644
index c90860e..0000000
--- a/dev-php/phpspec-prophecy/phpspec-prophecy-1.8.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="prophecy"
-MY_VENDOR="phpspec"
-
-DESCRIPTION="Highly opinionated mocking framework"
-HOMEPAGE="https://github.com/${MY_VENDOR}/${MY_PN}"
-SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-RDEPEND="
- dev-php/fedora-autoloader
- <dev-php/doctrine-instantiator-2
- <dev-php/phpdocumentor-reflection-docblock-5
- <dev-php/sebastian-comparator-4
- <dev-php/sebastian-recursion-context-4
- || (
- dev-lang/php:7.2
- dev-lang/php:7.1
- dev-lang/php:7.0
- )
-"
-
-src_install() {
- insinto /usr/share/php/${MY_VENDOR}/Prophecy
- doins -r src/Prophecy/*
- doins "${FILESDIR}/autoload.php"
-}