summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'class.portage.ebuild.php')
-rw-r--r--class.portage.ebuild.php5
1 files changed, 4 insertions, 1 deletions
diff --git a/class.portage.ebuild.php b/class.portage.ebuild.php
index 73391f6..3875f25 100644
--- a/class.portage.ebuild.php
+++ b/class.portage.ebuild.php
@@ -62,6 +62,9 @@
function __construct($str) {
+ global $hits;
+ $hits['ebuild']++;
+
$this->atom = trim($str);
$this->arr_suffix = array('alpha', 'beta', 'rc', 'pre', 'p');
$this->portage = '/usr/portage';
@@ -201,7 +204,7 @@
if(!is_null($this->arr_metadata))
return $this->arr_metadata;
- if(!file_exists($this->filename))
+ if(!file_exists($this->filename) || !file_exists($this->filename_cache))
return array();
$file = file($this->filename_cache, FILE_IGNORE_NEW_LINES);