summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/prado/prado-3.1.1_p2290.ebuild')
-rw-r--r--www-apps/prado/prado-3.1.1_p2290.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/www-apps/prado/prado-3.1.1_p2290.ebuild b/www-apps/prado/prado-3.1.1_p2290.ebuild
new file mode 100644
index 0000000..db87f38
--- /dev/null
+++ b/www-apps/prado/prado-3.1.1_p2290.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php
+
+MY_P="${PN}-${PV/_p/.r}"
+DESCRIPTION="a component-based and event-driven web programming framework"
+HOMEPAGE="http://www.pradosoft.com/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="BSD" # http://www.pradosoft.com/license/
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/httpd-cgi"
+
+S=${WORKDIR}/${MY_P}
+
+need_php5
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml -r docs/manual
+
+ cp -r framework/* "${D}${MY_HTDOCSDIR}"
+ cp framework/.htaccess "${D}${MY_HTDOCSDIR}"
+
+ webapp_src_install
+}