summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/roundcube/roundcube-0.1.ebuild')
-rw-r--r--mail-client/roundcube/roundcube-0.1.ebuild36
1 files changed, 28 insertions, 8 deletions
diff --git a/mail-client/roundcube/roundcube-0.1.ebuild b/mail-client/roundcube/roundcube-0.1.ebuild
index 995f8cb..1ddefb0 100644
--- a/mail-client/roundcube/roundcube-0.1.ebuild
+++ b/mail-client/roundcube/roundcube-0.1.ebuild
@@ -11,32 +11,52 @@ HOMEPAGE="http://www.roundcube.net"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components and utf8.class.php
-LICENSE="GPL-2 BSD PHP-2.02 PHP-3 public-domain"
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
KEYWORDS="~amd64 ~x86"
-IUSE="mysql postgres sqlite ssl"
+IUSE="ldap mysql postgres sqlite ssl spell"
+RDEPEND="dev-php/PEAR-PEAR"
need_httpd_cgi
need_php_httpd
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- local flags="crypt iconv imap pcre unicode"
+ local flags="crypt iconv imap pcre session socket unicode"
+ use ldap && flags="${flags} ldap"
use ssl && flags="${flags} ssl"
- use spell && flags="${flags} curl socket"
- local dbflags="mysql postgres sqlite"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
fi
else
- for db in ${dbflags} ; do
+ for db in postgres sqlite ; do
use ${db} && flags="${flags} ${db}"
done
- require_php_with_use ${flags}
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+ use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
+ use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
+ use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
+
webapp_pkg_setup
}