summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/vzctl/vzctl-3.0.14.ebuild')
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
index 77be6e1..4ba3927 100644
--- a/sys-cluster/vzctl/vzctl-3.0.14.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -29,28 +29,28 @@ src_unpack() {
}
src_compile() {
- econf || die "econf failed!"
+ econf --libdir=$(get_libdir) || die "econf failed!"
emake CFLAGS="${CFLAGS}" || die "emake failed!"
}
src_install() {
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install install-gentoo || die "make install failed"
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
# the get_libdir in `make install' breaks src/Makefile's logic (and thus all
# contained tools), so we have to create a env.d entry for vzctl's LDPATH.
- dodir /etc/env.d
- echo "LDPATH=\"/usr/$(get_libdir)/vzctl\"" > "${D}"/etc/env.d/05vzctl
+ #dodir /etc/env.d
+ #echo "LDPATH=\"/usr/$(get_libdir)/vzctl\"" > "${D}"/etc/env.d/05vzctl
# Remove udev files unless USE=udev
use udev || rm -rf "${D}"/etc/udev
# Remove the bash-completion and use dobashcompletion to install it in the
# right place!
- rm -rf "${D}"/etc/bash_completion.d
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+ #rm -rf "${D}"/etc/bash_completion.d
+ #dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
# Remove the logrotate entry unless USE=logrotate
- use logrotate || rm -rf "${D}"/etc/logrotate.d
+ #use logrotate || rm -rf "${D}"/etc/logrotate.d
}
pkg_postinst() {