summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/vzctl/vzctl-3.0.14.ebuild')
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
index 2891832..2f8c542 100644
--- a/sys-cluster/vzctl/vzctl-3.0.14.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.14.ebuild,v 1.1 2007/01/18 09:40:03 phreak Exp $
-inherit eutils multilib
+inherit bash-completion eutils multilib
DESCRIPTION="OpenVZ VPS control utility"
HOMEPAGE="http://openvz.org/"
@@ -11,7 +11,7 @@ SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
-IUSE="bash-completion logrotate udev"
+IUSE="logrotate udev"
RDEPEND="logrotate? ( app-admin/logrotate )
net-firewall/iptables
@@ -39,9 +39,14 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh.in vzctl
}
pkg_postinst() {
+ bash-completion_pkg_postinst
if has_version "<3.0.10"; then
ewarn
ewarn "The location of some vzctl files have changed. Most notably,"