summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patches/020_virtualbox-7.0.16-python.patch')
-rw-r--r--patches/020_virtualbox-7.0.16-python.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/patches/020_virtualbox-7.0.16-python.patch b/patches/020_virtualbox-7.0.16-python.patch
new file mode 100644
index 0000000..d96788e
--- /dev/null
+++ b/patches/020_virtualbox-7.0.16-python.patch
@@ -0,0 +1,20 @@
+Virtualbox 7.x will only build a lib named VBoxPython3.so, regardless of the
+actual python version used when compiling. Remove VBoxPython3m.so, we don't
+use it.
+
+--- a/src/libs/xpcom18a4/python/Makefile.kmk
++++ b/src/libs/xpcom18a4/python/Makefile.kmk
+@@ -711,13 +711,6 @@
+ VBoxPython3_DEFS = $(filter-out VBOX_PYXPCOM_VERSIONED,$(VBoxPythonBase_DEFS)) Py_LIMITED_API=0x03030000
+ VBoxPython3_INCS = $(VBoxPythonBase_INCS) $(VBOX_PYTHON$(VBOX_PYTHON_LIMITED_API_VER)_INC)
+ VBoxPython3_LDFLAGS.darwin = -undefined dynamic_lookup
+-
+- ifneq ($(KBUILD_TARGET),darwin)
+- DLLS += VBoxPython3m
+- VBoxPython3m_EXTENDS = VBoxPythonBase_m
+- VBoxPython3m_DEFS = $(filter-out VBOX_PYXPCOM_VERSIONED,$(VBoxPythonBase_m_DEFS)) Py_LIMITED_API=0x03030000
+- VBoxPython3m_INCS = $(VBoxPythonBase_m_INCS) $(VBOX_PYTHON$(VBOX_PYTHON_LIMITED_API_VER)_INC)
+- endif
+ endif
+ endif # VBOX_WITH_PYTHON_LIMITED_API
+