summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2015-05-02 15:58:23 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2015-05-02 15:58:23 -0500
commit4bd9670903829f38901356eae33c8ade04d32ed2 (patch)
tree74ea50e6fcd2e6dc0abf04fa308d3708bdfcfc99
parentDisable the scripts in a systemd-nspawn container (diff)
downloadudev-gentoo-scripts-4bd9670903829f38901356eae33c8ade04d32ed2.tar.gz
udev-gentoo-scripts-4bd9670903829f38901356eae33c8ade04d32ed2.tar.bz2
udev-gentoo-scripts-4bd9670903829f38901356eae33c8ade04d32ed2.zip
Convert dist target to git built-in tarball handling
The "git archive" command can create *.gz tarballs without piping through external utilities. The *.gz file is about the same size as a *.bz2 file, so using *.gz in this case doesn't change the size of the tarball significantly.
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9f88d4d..c0f63a1 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
-PACKAGE = udev-init-scripts
VERSION = 28
-DISTNAME = $(PACKAGE)-$(VERSION)
+PACKAGE = udev-init-scripts
+TARBALL = $(PACKAGE)-$(VERSION).tar.gz
SYSCONFDIR ?= /etc
CONFD ?= $(SYSCONFDIR)/conf.d
@@ -19,8 +19,7 @@ check-git-repository:
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
dist:
- git archive --format=tar --prefix=$(DISTNAME)/ $(VERSION) | \
- bzip2 > $(DISTNAME).tar.bz2
+ git archive --prefix=$(PACKAGE)-$(VERSION)/ $(VERSION) -o $(TARBALL)
snapshot: check-git-repository
git archive --format=tar --prefix=$(PACKAGE)/ HEAD | \