summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils/binutils-2.15.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.15.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.15.ebuild b/sys-devel/binutils/binutils-2.15.ebuild
new file mode 100644
index 0000000..4bef8bd
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.15.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+PATCHVER="1.3"
+UCLIBC_PATCHVER=""
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+KEYWORDS="-* ~x86-fbsd"
+
+src_unpack() {
+ tc-binutils_unpack
+
+ cd "${WORKDIR}"/patch
+ # *BSD patches are not safe
+ [[ ${CTARGET} != *-freebsd* ]] && mv 00_all_freebsd* skip/
+ [[ ${CTARGET} != *-openbsd* ]] && mv 00_all_openbsd* skip/
+
+ tc-binutils_apply_patches
+}