summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sshguard/sshguard-0.91-r1.ebuild')
-rw-r--r--net-misc/sshguard/sshguard-0.91-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/sshguard/sshguard-0.91-r1.ebuild b/net-misc/sshguard/sshguard-0.91-r1.ebuild
new file mode 100644
index 000000000..a5081672c
--- /dev/null
+++ b/net-misc/sshguard/sshguard-0.91-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-firewall/iptables"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-pam.patch"
+}
+src_compile() {
+ econf --with-firewall=iptables
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}