summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/chocolate-doom/chocolate-doom-9999.ebuild')
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-9999.ebuild80
1 files changed, 50 insertions, 30 deletions
diff --git a/games-fps/chocolate-doom/chocolate-doom-9999.ebuild b/games-fps/chocolate-doom/chocolate-doom-9999.ebuild
index 26a0a7032..3d03a3447 100644
--- a/games-fps/chocolate-doom/chocolate-doom-9999.ebuild
+++ b/games-fps/chocolate-doom/chocolate-doom-9999.ebuild
@@ -4,66 +4,86 @@
EAPI=5
-PYTHON_COMPAT=( python2_6 python2_7 )
-inherit autotools subversion python-any-r1 flag-o-matic games
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+EGIT_REPO_URI="https://github.com/chocolate-doom/chocolate-doom.git"
-DESCRIPTION="Doom port designed to act identically to the original game"
+inherit eutils autotools python-any-r1 games git-2
+
+DESCRIPTION="Doom, Heretic, Hexen and Strife port designed to act identically to original games"
HOMEPAGE="http://www.chocolate-doom.org/"
-ESVN_REPO_URI="https://chocolate-doom.svn.sourceforge.net/svnroot/${PN}/trunk/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="server"
+IUSE="+doom heretic hexen strife server timidity"
-DEPEND=">=media-libs/libsdl-1.1.3
- media-libs/sdl-mixer
+RDEPEND="media-libs/libsamplerate
+ >=media-libs/libsdl-1.1.3:0
+ media-libs/sdl-mixer[timidity?]
media-libs/sdl-net"
-RDEPEND=${DEPEND}
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
-pkg_setup () {
+pkg_setup() {
games_pkg_setup
python-any-r1_pkg_setup
}
-src_unpack() {
- subversion_src_unpack
-}
-
src_prepare() {
# Change default search path for IWAD
sed -i \
-e "s:/usr/share/games/doom:${GAMES_DATADIR}/doom-data:" \
- src/d_iwad.c || die "sed main.c failed"
-
+ src/d_iwad.c man/INSTALL.template || die "sed failed"
sed -i \
-e "s:^gamesdir =.*:gamesdir = ${GAMES_BINDIR}:" \
- setup/Makefile.am || die "sed Makefile.am failed"
+ src/setup/Makefile.am || die "sed Makefile.am failed"
- append-libs -lm
eautoreconf
}
src_configure() {
egamesconf \
- --disable-sdltest \
- --disable-dependency-tracking
+ --disable-sdltest
}
src_install() {
- dogamesbin "src/${PN}"
- dogamesbin setup/chocolate-setup
+ doicon data/${PN}.png
+ doicon data/chocolate-setup.png
+
+ dogamesbin src/chocolate-setup
+ make_desktop_entry chocolate-setup "Chocolate Setup" \
+ chocolate-setup "Settings"
+ doman man/chocolate-setup.6
+ doman man/default.cfg.5
+
+ local opt game game_full
+ for opt in "doom Doom" \
+ "heretic Heretic" \
+ "strife Strife" \
+ "hexen Hexen"
+ do
+ game=${opt%% *}
+ game_full=${opt#* }
+ if use $game ; then
+ dogamesbin src/chocolate-${game}
+ dosym chocolate-setup "${GAMES_BINDIR}/chocolate-${game}-setup"
+
+ make_desktop_entry chocolate-${game} \
+ "Chocolate ${game_full}" ${PN} "Game;Shooter"
+ make_desktop_entry chocolate-${game}-setup \
+ "Chocolate ${game_full} Setup" chocolate-setup "Settings"
+
+ doman man/*${game}*.{5,6}
+ fi
+ done
+
if use server ; then
dogamesbin src/chocolate-server
+ doman man/chocolate-server.6
fi
- newicon data/doom.png "${PN}.png"
- make_desktop_entry "${PN}" "Chocolate Doom"
- newicon data/setup.png chocolate-setup.png
- make_desktop_entry chocolate-setup "Chocolate Doom Setup" chocolate-setup.png
-
- nonfatal doman man/*.{5,6}
- nonfatal dodoc AUTHORS BUGS CMDLINE ChangeLog NEWS README TODO
+ domenu src/${PN}-screensaver.desktop
+ dodoc AUTHORS ChangeLog HACKING NEWS NOT-BUGS README* TODO
keepdir "${GAMES_DATADIR}/doom-data"
@@ -75,8 +95,8 @@ pkg_postinst() {
einfo
einfo "To play the original Doom levels, place doom.wad and/or doom2.wad"
- einfo "into "${GAMES_DATADIR}"/doom-data, then run: ${PN}"
+ einfo "into ${GAMES_DATADIR}/doom-data, then run: ${PN}"
einfo
- einfo "To configure game options run: chocolate-setup"
+ einfo "To configure game options run: chocolate-setup"
einfo
}