summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtem Sidorenko (Scader) <artem@2realities.com>2012-01-29 13:45:55 +0000
committerArtem Sidorenko (Scader) <artem@2realities.com>2012-01-29 13:45:55 +0000
commitb3ddc68f08fd5fd29f80e69c87e2554b606acc94 (patch)
tree757247a785ffc534ceda84b8def5dae8626ae888 /www-apache
parentdev-games/renpy-modules: Fixed invalid Manifest (diff)
downloadsunrise-b3ddc68f08fd5fd29f80e69c87e2554b606acc94.tar.gz
sunrise-b3ddc68f08fd5fd29f80e69c87e2554b606acc94.tar.bz2
sunrise-b3ddc68f08fd5fd29f80e69c87e2554b606acc94.zip
www-apache/mod_authn_otp: New ebuild for bug 401273
svn path=/sunrise/; revision=12714
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_authn_otp/ChangeLog10
-rw-r--r--www-apache/mod_authn_otp/Manifest5
-rw-r--r--www-apache/mod_authn_otp/files/70_mod_authn_otp.conf5
-rw-r--r--www-apache/mod_authn_otp/metadata.xml5
-rw-r--r--www-apache/mod_authn_otp/mod_authn_otp-1.1.4.ebuild39
5 files changed, 64 insertions, 0 deletions
diff --git a/www-apache/mod_authn_otp/ChangeLog b/www-apache/mod_authn_otp/ChangeLog
new file mode 100644
index 000000000..d62379e34
--- /dev/null
+++ b/www-apache/mod_authn_otp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apache/mod_authn_otp
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mod_authn_otp-1.1.4 (29 Jan 2012)
+
+ 29 Jan 2012; Artem Sidorenko (Scader) <artem@2realities.com>
+ +files/70_mod_authn_otp.conf, +mod_authn_otp-1.1.4.ebuild, +metadata.xml:
+ New ebuild for bug 401273
+
diff --git a/www-apache/mod_authn_otp/Manifest b/www-apache/mod_authn_otp/Manifest
new file mode 100644
index 000000000..c57272436
--- /dev/null
+++ b/www-apache/mod_authn_otp/Manifest
@@ -0,0 +1,5 @@
+AUX 70_mod_authn_otp.conf 115 RMD160 b83b94a760cbff20381abf941d1d060b6ba8c35c SHA1 c66faa883e035406f83d2f8e39b3d9ddd9ae0341 SHA256 331bbb8b2894054ba2895695cfff49a193a98ee1cb7e92408b8bf747737e5864
+DIST mod_authn_otp-1.1.4.tar.gz 94911 RMD160 d1082f45fc94f042fd6b883152a5739b5a354d78 SHA1 cc1e3bebd3a2bf66fea6f4bf5e609e8bdc822040 SHA256 f1dad6741ec2904637c251bee88f50156df611a9ebdbcf0abf64471c4a3987c0
+EBUILD mod_authn_otp-1.1.4.ebuild 825 RMD160 470824b8f4fc9e801f0d439633c4ec2524e05a2e SHA1 035e0472bd1d7bb94e6035ca584eb0b8132e3574 SHA256 03466f82e9f08b7ea7b0203c9da7b7b155d63e59d9826330899adbf0a4ee97c2
+MISC ChangeLog 329 RMD160 8bac1938bc8dbc53960bb38806f95d67cf80fb73 SHA1 4fc9e3d59767a377c6021e2aaff0b0e7df3ce87d SHA256 2a715425501458cabe585c8277945d1ab03a2df70fca286cd6002b061d2bf4c6
+MISC metadata.xml 200 RMD160 2b20a5237211e577262ebf219e34d06b2730696e SHA1 b3bd01b0092be80c3d1629a13aa3b64adb7a701b SHA256 d25604d7a348fbc2d7592b6b439fdd9b470416a8ab201fee69a445ebe1a9985e
diff --git a/www-apache/mod_authn_otp/files/70_mod_authn_otp.conf b/www-apache/mod_authn_otp/files/70_mod_authn_otp.conf
new file mode 100644
index 000000000..20bc2cccf
--- /dev/null
+++ b/www-apache/mod_authn_otp/files/70_mod_authn_otp.conf
@@ -0,0 +1,5 @@
+<IfDefine AUTHN_OTP>
+LoadModule authn_otp_module modules/mod_authn_otp.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_authn_otp/metadata.xml b/www-apache/mod_authn_otp/metadata.xml
new file mode 100644
index 000000000..57a348d5c
--- /dev/null
+++ b/www-apache/mod_authn_otp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>artem@2realities.com</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_authn_otp/mod_authn_otp-1.1.4.ebuild b/www-apache/mod_authn_otp/mod_authn_otp-1.1.4.ebuild
new file mode 100644
index 000000000..ca59d76d7
--- /dev/null
+++ b/www-apache/mod_authn_otp/mod_authn_otp-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit apache-module
+
+DESCRIPTION="An Apache module for two-factor authentication (HOTP/OATH)"
+HOMEPAGE="http://code.google.com/p/mod-authn-otp/"
+SRC_URI="http://mod-authn-otp.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="AUTHN_OTP"
+
+DOCFILES="README users.sample CHANGES"
+
+need_apache2
+
+src_compile() {
+ default
+}
+
+src_install() {
+ apache-module_src_install
+ doman otptool.1 || die "doman failed"
+ dobin otptool || die "dobin failed"
+}
+
+pkg_postinst(){
+ apache-module_pkg_postinst
+ elog "For configuration information see:"
+ elog " http://code.google.com/p/mod-authn-otp/wiki/Configuration"
+}