summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2011-01-24 21:41:55 +0000
committerNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2011-01-24 21:41:55 +0000
commit481202d81673dc9d55a4e94b5398df305128e605 (patch)
tree3e8d5d7ecd95a98e0e98bee2714ca99775e1c1ba /sys-devel
parentx11-plugins/imgur-integration: New ebuild for bug #352541 (diff)
downloadsunrise-481202d81673dc9d55a4e94b5398df305128e605.tar.gz
sunrise-481202d81673dc9d55a4e94b5398df305128e605.tar.bz2
sunrise-481202d81673dc9d55a4e94b5398df305128e605.zip
sys-devel/boost-m4: New ebuild sys-devel/boost-m4-0.1 for bug 352618.
(Portage version: 2.2.0_alpha17-r1/svn/Linux x86_64) svn path=/sunrise/; revision=11726
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/boost-m4/ChangeLog10
-rw-r--r--sys-devel/boost-m4/Manifest5
-rw-r--r--sys-devel/boost-m4/boost-m4-0.1.ebuild43
-rw-r--r--sys-devel/boost-m4/files/boost-m4-0.1-multilib.patch31
-rw-r--r--sys-devel/boost-m4/metadata.xml6
5 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/boost-m4/ChangeLog b/sys-devel/boost-m4/ChangeLog
new file mode 100644
index 000000000..38a7a6d2d
--- /dev/null
+++ b/sys-devel/boost-m4/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/boost-m4
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*boost-m4-0.1 (24 Jan 2011)
+
+ 24 Jan 2011; Nathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>
+ +boost-m4-0.1.ebuild, +files/boost-m4-0.1-multilib.patch, +metadata.xml:
+ New ebuild sys-devel/boost-m4-0.1 for bug 352618.
+
diff --git a/sys-devel/boost-m4/Manifest b/sys-devel/boost-m4/Manifest
new file mode 100644
index 000000000..82cd9b065
--- /dev/null
+++ b/sys-devel/boost-m4/Manifest
@@ -0,0 +1,5 @@
+AUX boost-m4-0.1-multilib.patch 1084 RMD160 9d2f912b70c433c60f0ff77afb9f77499f9eda01 SHA1 556b550b1e5b34795579a1abf2d045c6336ffa77 SHA256 b68d6a6cddca079e08f2b680c7d2bbf596dd42fcf8dbe655138206008ff0b286
+DIST boost-m4-0.1.zip 41061 RMD160 b4f0a4f5035e1467f4d11e7b73c155fbe6b52d59 SHA1 b5745fdcd1e5fb1212ad611b0c9edb6f68eef292 SHA256 a1ef028bb39cc724791a2ab15fe133187fafeef132eb4e189251bc3cbc4b1461
+EBUILD boost-m4-0.1.ebuild 830 RMD160 86d819b16f79c229c71916d2558beca56e83d1b4 SHA1 3371bd81acaa2bd06cbcebf062dcf9a38f7a8c1d SHA256 0ff8beeb7e2c0d34ad3a2def2167858393f851857801c460ee931a5f510fce52
+MISC ChangeLog 351 RMD160 eccec62714c5ccf32a406eef50dd79674487b496 SHA1 706651cea9b648e0883e58922d7501d105fee134 SHA256 917f03093a045233358b28a0a0e35ad704d390dbd3b4544a6828830c832a1cc9
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/sys-devel/boost-m4/boost-m4-0.1.ebuild b/sys-devel/boost-m4/boost-m4-0.1.ebuild
new file mode 100644
index 000000000..8e0014593
--- /dev/null
+++ b/sys-devel/boost-m4/boost-m4-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Another set of autoconf macros for compiling against boost"
+HOMEPAGE="http://github.com/tsuna/boost.m4"
+SRC_URI="${HOMEPAGE}/zipball/v${PV} -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ default
+
+ mv * ${P} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-multilib.patch
+}
+
+# boost.m4 has a buildsystem which doesn't build nor install
+# anything. It only would add a buildtime dependency that boost be
+# installed. Thus, noop it:
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins build-aux/boost.m4 || die
+
+ dodoc AUTHORS NEWS README THANKS || die
+}
diff --git a/sys-devel/boost-m4/files/boost-m4-0.1-multilib.patch b/sys-devel/boost-m4/files/boost-m4-0.1-multilib.patch
new file mode 100644
index 000000000..5edb5b373
--- /dev/null
+++ b/sys-devel/boost-m4/files/boost-m4-0.1-multilib.patch
@@ -0,0 +1,31 @@
+From a08684994caf88f28c758c7d579dae92fe69d0fa Mon Sep 17 00:00:00 2001
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Date: Mon, 24 Jan 2011 01:48:25 -0500
+Subject: [PATCH 2/2] Support multilib installations which use both lib32 and lib64.
+
+---
+ build-aux/boost.m4 | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/build-aux/boost.m4 b/build-aux/boost.m4
+index 2ba29bf..3d271f6 100644
+--- a/build-aux/boost.m4
++++ b/build-aux/boost.m4
+@@ -22,2 +22,2 @@
+
+-# serial 6
++# serial 6+15
+@@ -379,8 +379,8 @@ for boost_rtopt_ in $boost_rtopt '' -d; do
+ boost_tmp_lib=$with_boost
+ test x"$with_boost" = x && boost_tmp_lib=${boost_cv_inc_path%/include}
+ for boost_ldpath in "$boost_tmp_lib/lib" '' \
+- /opt/local/lib /usr/local/lib /opt/lib /usr/lib \
+- "$with_boost" C:/Boost/lib /lib /usr/lib64 /lib64
++ /opt/local/lib* /usr/local/lib* /opt/lib* /usr/lib* \
++ "$with_boost" C:/Boost/lib /lib*
+ do
+ test -e "$boost_ldpath" || continue
+ boost_save_LDFLAGS=$LDFLAGS
+--
+1.7.2.2
+
diff --git a/sys-devel/boost-m4/metadata.xml b/sys-devel/boost-m4/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/sys-devel/boost-m4/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>