summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-09-25 15:25:56 +0000
committerJakub Moc <jakub@gentoo.org>2007-09-25 15:25:56 +0000
commit137f40ef8da8945353ed7793616fdb4eebd03604 (patch)
tree934e627d46076cad29a3d13520347afcf302e62b /games-board
parentsci-calculators/tiemu3: Remove bogus USE=debug (diff)
downloadsunrise-137f40ef8da8945353ed7793616fdb4eebd03604.tar.gz
sunrise-137f40ef8da8945353ed7793616fdb4eebd03604.tar.bz2
sunrise-137f40ef8da8945353ed7793616fdb4eebd03604.zip
games-board/pokerth: Use eqmake4, ebuild cleanup
svn path=/sunrise/; revision=4718
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog3
-rw-r--r--games-board/pokerth/Manifest4
-rw-r--r--games-board/pokerth/pokerth-0.5.ebuild20
3 files changed, 12 insertions, 15 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 115995d58..ed7ce88f5 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Sep 2007; Jakub Moc <jakub@gentoo.org> pokerth-0.5.ebuild:
+ Use eqmake4, ebuild cleanup
+
24 Sep 2007; Thomas Pani (thpani) <thomas.pani@gmail.com>
pokerth-0.5.ebuild:
Added media-libs/libmikmod dependency. Thanks to Tobias Kral <tobias@kral.ws>.
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
index 937c6fa8a..52dae2924 100644
--- a/games-board/pokerth/Manifest
+++ b/games-board/pokerth/Manifest
@@ -1,4 +1,4 @@
DIST PokerTH-0.5-src.tar.bz2 4123606 RMD160 d322aecd9c44d301bb3c3ba3fc7c33bf6a6114db SHA1 344a1afcef123d4947e39e667fb310160a985958 SHA256 a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d
-EBUILD pokerth-0.5.ebuild 1517 RMD160 921593fc4823ee90affb390baa23aebc1979723a SHA1 c2c97ae9a4ec35f4946389890f1f9ede8e7cb3d0 SHA256 1125f9be5d398f60d45b5d26fb2429fc63360ead957cc5aa70f6f48657921079
-MISC ChangeLog 444 RMD160 2d607bab4186abe9008fb2e01f3b7bfb1c56d687 SHA1 84b0189774e1740fdd37f88e1c75925a157d6fe7 SHA256 e1ffa5fef086d3e0a381c2ed39ad4a9e5217aa69eacda4f5862a722810cc3f6e
+EBUILD pokerth-0.5.ebuild 1433 RMD160 908a6e52df79655eb230ecf57872eff05a605774 SHA1 6943b4db9f87f9f5d722d46aa95920fe2b683d1d SHA256 5d31d3fc8ec0939520ac5c4e99e36b3206218037c987593a947baba1957c6c39
+MISC ChangeLog 539 RMD160 4d39a574d4d7aee6d240cf15457ebfd91f932764 SHA1 f16c10504ecbd5a80653831b37556c2de26aaf86 SHA256 2716f509309ebbd3aa01aaed1360eb442711f613092c0df938b72d743824e620
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-board/pokerth/pokerth-0.5.ebuild b/games-board/pokerth/pokerth-0.5.ebuild
index 958566b0b..568997bc9 100644
--- a/games-board/pokerth/pokerth-0.5.ebuild
+++ b/games-board/pokerth/pokerth-0.5.ebuild
@@ -25,24 +25,18 @@ DEPEND="$(qt4_min_version 4.2.3)
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! built_with_use "x11-libs/qt" qt3support ; then
- eerror "x11-libs/qt has to be compiled with 'qt3support'"
- eerror "USE-flag enabled."
- die "Needed USE-flag for x11-libs/qt not found."
+ if ! built_with_use "=x11-libs/qt-4*" qt3support ; then
+ eerror "x11-libs/qt has to be compiled with USE=qt3support"
+ die "Needed USE-flag for QT4 not found."
fi
- if has_version "<dev-libs/boost-1.34" && \
- ! built_with_use "dev-libs/boost" threads
- then
- eerror "dev-libs/boost has to be compiled with 'threads'"
- eerror "USE-flag enabled."
+ if has_version "<dev-libs/boost-1.34" && ! built_with_use "dev-libs/boost" threads ; then
+ eerror "dev-libs/boost has to be compiled with USE=threads"
die "Needed USE-flag for dev-libs/boost not found."
fi
# Qt bug #171858, fixed in 4.3.2 and 4.4.0
- if has_version "~x11-libs/qt-4.3.0" || \
- has_version "~x11-libs/qt-4.3.1"
- then
+ if has_version "~x11-libs/qt-4.3.0" || has_version "~x11-libs/qt-4.3.1" ; then
ewarn "x11-libs/qt versions 4.3.0 and 4.3.1 are known to break"
ewarn "stylesheet support for buttons (game is still playable)."
fi
@@ -51,7 +45,7 @@ pkg_setup() {
}
src_compile() {
- qmake || die "qmake failed."
+ eqmake4
emake || die "emake failed."
}