summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mlocate/mlocate-0.17.ebuild')
-rw-r--r--sys-apps/mlocate/mlocate-0.17.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/mlocate/mlocate-0.17.ebuild b/sys-apps/mlocate/mlocate-0.17.ebuild
index 3764a5308..4e2c5a254 100644
--- a/sys-apps/mlocate/mlocate-0.17.ebuild
+++ b/sys-apps/mlocate/mlocate-0.17.ebuild
@@ -13,6 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="usersandbox"
RDEPEND="!sys-apps/slocate
!sys-apps/rlocate"
@@ -46,10 +47,10 @@ src_install() {
}
src_test() {
- if has userpriv ${FEATURES} && ! has usersandbox ${FEATURES}; then
+ if has userpriv ${FEATURES}; then
make check-local || die "test suite failed"
else
- ewarn "Activate FEATURES=userpriv and deactivate FEATURES=usersandbox to run testsuite."
+ ewarn "Activate FEATURES=userpriv to run testsuite."
fi
}