summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-05 21:48:19 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-05 21:48:19 +0000
commit33c4bde6c40fa4d5a2e603a2210d2ad2b872bc86 (patch)
tree542fc9cef92dfd082a79c1e1a241fb2ee6466aa9 /www-plugins
parentadd www-plugins to profiles/categories (diff)
downloadsunrise-reviewed-33c4bde6c40fa4d5a2e603a2210d2ad2b872bc86.tar.gz
sunrise-reviewed-33c4bde6c40fa4d5a2e603a2210d2ad2b872bc86.tar.bz2
sunrise-reviewed-33c4bde6c40fa4d5a2e603a2210d2ad2b872bc86.zip
www-plugins/mozilla-weave: new ebuild for bug 235397
svn path=/sunrise/; revision=8196
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog8
-rw-r--r--www-plugins/mozilla-weave/Manifest4
-rw-r--r--www-plugins/mozilla-weave/metadata.xml5
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild82
4 files changed, 99 insertions, 0 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
new file mode 100644
index 000000000..e14ddd4cf
--- /dev/null
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for www-plugins/mozilla-weave
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 05 Apr 2009; Mounir Lamouri (volkmar) <mounir.lamouri@gmail.com>
+ +mozilla-weave-0.2.104.ebuild, +metadata.xml:
+ new ebuild for bug 235397
+
diff --git a/www-plugins/mozilla-weave/Manifest b/www-plugins/mozilla-weave/Manifest
new file mode 100644
index 000000000..f4085453a
--- /dev/null
+++ b/www-plugins/mozilla-weave/Manifest
@@ -0,0 +1,4 @@
+DIST mozilla-weave-0.2.104.tar.gz 459124 RMD160 78daa66bc43e018377ab2e8c464530932ab2cb0f SHA1 faf2cac02b7c3018b5c634656795e72fe355d369 SHA256 e80fe8e917ea5fce01fa0e009aec2f95925003ee7dda10e5c30fa22ef1ec0ed0
+EBUILD mozilla-weave-0.2.104.ebuild 2268 RMD160 33f6751070ff99e25501165817bbb999f0910e65 SHA1 681e7a8039dc98ad04ab919fd56fc656eb69db61 SHA256 f2d69aa715519c61a348de4eabed0624d498924d71a86f261cf0137317b28edb
+MISC ChangeLog 270 RMD160 6b8f9fe209b8274168257249f7d76b9c4b3e796b SHA1 7c3601a49cdad28e93593a322c17c154973f6966 SHA256 8c36d0fe2106134bb54ce2c41b7c572c1b21beeb3002bd6b6ae157ee45bc3689
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/www-plugins/mozilla-weave/metadata.xml b/www-plugins/mozilla-weave/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/www-plugins/mozilla-weave/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild
new file mode 100644
index 000000000..5b66f21da
--- /dev/null
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.2.104.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit mozextension multilib
+
+MY_PN="weave"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Mozilla Labs prototype for online services"
+HOMEPAGE="http://labs.mozilla.com/projects/weave/"
+SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/index.cgi/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-3
+ >=www-client/mozilla-firefox-bin-3
+ )
+ net-libs/xulrunner:1.9
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# NOTES:
+# there are tests but they don't break the build if not working
+# thunderbird and fennec are in install.rdf
+
+src_prepare() {
+ # we want to use system nss and nspr
+ sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
+ src/Makefile || die "patching Makefile failed"
+ sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
+ src/Makefile || die "patching Makefile failed"
+
+ # remove useless platforms
+ rm -fr platform/* || die "rm -rf never dies"
+
+ # ppc arch is not recognized on Linux
+ # upstream has been contacted w/patch, see bug 486797 in upstream bugtracker
+ sed -i -e "s/Power Macintosh/ppc/" src/Makefile \
+ || die "patching src/Makefile failed"
+}
+
+src_compile() {
+ export XULRUNNER_BIN=/usr/bin/xulrunner-1.9
+ export WEAVE_BUILDID=${PV}
+ export MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
+
+ emake release_build=1 xpi || "emake failed"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+
+ # recommanded usage is to launch firefox with xpi as a parameter
+ # so, we unzip the file and intsall it with mozextension tools
+ unzip -qo "${MY_P}-rel.xpi" -d "${MY_P}"
+
+ if has_version '>=www-client/mozilla-firefox-3.0'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-3.0'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use Weave, you have to get an account at https://services.mozilla.com/"
+ einfo "Otherwise, you can setup your own server, see:"
+ einfo "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
+}