summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Pani (thpani) <thomas.pani@gmail.com>2007-08-18 09:30:40 +0000
committerThomas Pani (thpani) <thomas.pani@gmail.com>2007-08-18 09:30:40 +0000
commit63ced8eb51043ea3f4c99a26e68b517eb950cb33 (patch)
tree69a0f306dc034f0219aea8707bf01c23815216ae /games-board
parentremoved proftpd and drftpd, added unintentionally <jsin@gentoo.org> (diff)
downloadsunrise-reviewed-63ced8eb51043ea3f4c99a26e68b517eb950cb33.tar.gz
sunrise-reviewed-63ced8eb51043ea3f4c99a26e68b517eb950cb33.tar.bz2
sunrise-reviewed-63ced8eb51043ea3f4c99a26e68b517eb950cb33.zip
games-board/pokerth: New Ebuild for bug 169238, reviewed by jsin and shillelagh
svn path=/sunrise/; revision=4455
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog8
-rw-r--r--games-board/pokerth/Manifest4
-rw-r--r--games-board/pokerth/files/digest-pokerth-0.53
-rw-r--r--games-board/pokerth/metadata.xml5
-rw-r--r--games-board/pokerth/pokerth-0.5.ebuild64
5 files changed, 84 insertions, 0 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
new file mode 100644
index 000000000..690037f88
--- /dev/null
+++ b/games-board/pokerth/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-board/pokerth
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 18 Aug 2007; Thomas Pani (thpani) <thomas.pani@gmail.com> +metadata.xml,
+ +pokerth-0.5.ebuild:
+ New Ebuild for bug 169238, reviewed by jsin and shillelagh
+
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
new file mode 100644
index 000000000..382e7bb15
--- /dev/null
+++ b/games-board/pokerth/Manifest
@@ -0,0 +1,4 @@
+DIST PokerTH-0.5-src.tar.bz2 4123606 RMD160 d322aecd9c44d301bb3c3ba3fc7c33bf6a6114db SHA1 344a1afcef123d4947e39e667fb310160a985958 SHA256 a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d
+EBUILD pokerth-0.5.ebuild 1496 RMD160 0293e94a4a361c7691a5435583be1a8e0cf80c82 SHA1 63ce5a0dff87b165e442b962e9caae507dfe3f4a SHA256 0c3d0feb53e3b66ff428e0f3b024836e1bd0552a281670a7f560f3b761ff6967
+MISC ChangeLog 280 RMD160 293a2466b42f5f3d2ec0e063a54bfd87fa9684c0 SHA1 6c9f12cb35e03bcf615926423c415bc8040861f4 SHA256 e24f3eba95713a5f1323c6d67396f407ac838eb711a70345a06de76b5a57d1e1
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-board/pokerth/files/digest-pokerth-0.5 b/games-board/pokerth/files/digest-pokerth-0.5
new file mode 100644
index 000000000..8f187412e
--- /dev/null
+++ b/games-board/pokerth/files/digest-pokerth-0.5
@@ -0,0 +1,3 @@
+MD5 1009e927b5d26b4eeb89d00cd4b624f7 PokerTH-0.5-src.tar.bz2 4123606
+RMD160 d322aecd9c44d301bb3c3ba3fc7c33bf6a6114db PokerTH-0.5-src.tar.bz2 4123606
+SHA256 a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d PokerTH-0.5-src.tar.bz2 4123606
diff --git a/games-board/pokerth/metadata.xml b/games-board/pokerth/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-board/pokerth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/games-board/pokerth/pokerth-0.5.ebuild b/games-board/pokerth/pokerth-0.5.ebuild
new file mode 100644
index 000000000..932f98284
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games qt4
+
+MY_PN="PokerTH"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DESCRIPTION="Texas Hold'em poker game."
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.2.3)
+ >=dev-libs/boost-1.33
+ >=dev-libs/openssl-0.9.7
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use "x11-libs/qt" qt3support ; then
+ eerror "x11-libs/qt has to be compiled with 'qt3support'"
+ eerror "USE-flag enabled."
+ die "Needed USE-flag for x11-libs/qt not found."
+ fi
+
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads
+ then
+ eerror "dev-libs/boost has to be compiled with 'threads'"
+ eerror "USE-flag enabled."
+ die "Needed USE-flag for dev-libs/boost not found."
+ fi
+
+ # Qt bug #171858, fixed in 4.3.2 and 4.4.0
+ if has_version "~x11-libs/qt-4.3.0" || \
+ has_version "~x11-libs/qt-4.3.1"
+ then
+ ewarn "x11-libs/qt versions 4.3.0 and 4.3.1 are known to break"
+ ewarn "stylesheet support for buttons (game is still playable)."
+ fi
+
+ games_pkg_setup
+}
+
+src_compile() {
+ qmake || die "qmake failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ dogamesbin bin/pokerth
+ newicon pokerth.png "${PN}.png"
+ make_desktop_entry "${PN}" "PokerTH" "${PN}.png"
+
+ prepgamesdirs
+}
+