summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2007-08-23 14:01:02 +0000
committerFederico Ferri <mescalinum@gentoo.org>2007-08-23 14:01:02 +0000
commitbc74542193d20b03da680db5d42d8b4114340c41 (patch)
tree2a3d62f888374b126e8f0aa569dc76b979f28f54 /games-action
parentgames-rpg/simon2-demo: Added redundant SRC_URI (diff)
downloadsunrise-reviewed-bc74542193d20b03da680db5d42d8b4114340c41.tar.gz
sunrise-reviewed-bc74542193d20b03da680db5d42d8b4114340c41.tar.bz2
sunrise-reviewed-bc74542193d20b03da680db5d42d8b4114340c41.zip
New Ebuild for bug 181418
svn path=/sunrise/; revision=4492
Diffstat (limited to 'games-action')
-rw-r--r--games-action/ballistics-demo/ChangeLog8
-rw-r--r--games-action/ballistics-demo/Manifest4
-rw-r--r--games-action/ballistics-demo/ballistics-demo-1.ebuild61
-rw-r--r--games-action/ballistics-demo/metadata.xml5
4 files changed, 78 insertions, 0 deletions
diff --git a/games-action/ballistics-demo/ChangeLog b/games-action/ballistics-demo/ChangeLog
new file mode 100644
index 000000000..71829ca07
--- /dev/null
+++ b/games-action/ballistics-demo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-action/ballistics-demo
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 23 Aug 2007; Federico Ferri (federico__) <mescalinum@gmail.com>
+ +metadata.xml, +ballistics-demo-1.ebuild:
+ New Ebuild for bug 181418
+
diff --git a/games-action/ballistics-demo/Manifest b/games-action/ballistics-demo/Manifest
new file mode 100644
index 000000000..ea28e7dce
--- /dev/null
+++ b/games-action/ballistics-demo/Manifest
@@ -0,0 +1,4 @@
+DIST ballistics-demo.run 108811943 RMD160 cbb641d96748619c68daa711d9ca4e752dce7464 SHA1 1a61d2647761c282e25307dc946f5592b93187f9 SHA256 cfcccddebe92d86787ab331ac3284cc926913943fe96bb14a5bc0e1702183548
+EBUILD ballistics-demo-1.ebuild 1434 RMD160 f79a35422d8af88f9b3e09e1af3395cc9187d17b SHA1 46368171e3de2dad7b953d6f074459687f2fda85 SHA256 4ec142b7bee8597a87e6d51a7487ed97809e905293bd9c9cb4b1e3666377dcbe
+MISC ChangeLog 268 RMD160 f4c864aa23d51490eedd35b2a32ccb58e9158c2a SHA1 a76aeba8155aa13c3c0862463a532a6efb2a4781 SHA256 3d41b479059960fbd9424bc437baaff05f5d98e44a9328e9518e7f7b93c6b8d0
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-action/ballistics-demo/ballistics-demo-1.ebuild b/games-action/ballistics-demo/ballistics-demo-1.ebuild
new file mode 100644
index 000000000..97cbbff0a
--- /dev/null
+++ b/games-action/ballistics-demo/ballistics-demo-1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="Super-fast 3D racing on hover bikes"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=ballistics"
+# Patches: http://updatefiles.linuxgamepublishing.com/ballistics-demo/
+# Unversioned filename, grrr (is pre-patched).
+SRC_URI="http://demofiles.linuxgamepublishing.com/ballistics/${PN}.run"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+# Not bothering with "dynamic" USE flag.
+# Uses OSS for audio.
+# dynamic? ( dev-games/libgrapple )
+RDEPEND="
+ x86? (
+ media-libs/libsdl
+ x11-libs/gtk+
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi )
+ amd64? (
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-sdl )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself ${PN}.run
+ unpack ./data/data.tar.gz
+
+ rm -rf data lgp_* setup*
+
+ mv bin "${T}" || die "mv"
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ exeinto "${dir}"
+ doexe "${T}"/bin/Linux/x86/* || die "doexe"
+
+ insinto "${dir}"
+ doins -r * || die "doins -r"
+
+ games_make_wrapper ${PN}-config ./ballistics_demo-config "${dir}" "${dir}"
+ games_make_wrapper ${PN} ./ballistics_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm || die "newicon"
+ make_desktop_entry ${PN} "Ballistics (Demo)" ${PN}.xpm
+
+ prepgamesdirs
+}
diff --git a/games-action/ballistics-demo/metadata.xml b/games-action/ballistics-demo/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-action/ballistics-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>