summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJure Varlec (exzombie) <jure.varlec@gmail.com>2010-01-08 16:35:22 +0000
committerJure Varlec (exzombie) <jure.varlec@gmail.com>2010-01-08 16:35:22 +0000
commitd730850069e54455addc7af73013bc6be5c8b0f1 (patch)
tree2c2770c6e0da7f067bdb38d58542ea681dce0a4f /app-shells
parentsci-misc/ised: Added ~amd64 keyword. Thanks to Wizzleby for testing. (diff)
downloadsunrise-reviewed-d730850069e54455addc7af73013bc6be5c8b0f1.tar.gz
sunrise-reviewed-d730850069e54455addc7af73013bc6be5c8b0f1.tar.bz2
sunrise-reviewed-d730850069e54455addc7af73013bc6be5c8b0f1.zip
app-shells/prll: New ebuild for bug #299798. Thanks to dilfridge and Tommy[D]. Also thanks to Wizzleby for amd64 testing.
svn path=/sunrise/; revision=9829
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/prll/ChangeLog9
-rw-r--r--app-shells/prll/Manifest5
-rw-r--r--app-shells/prll/files/prll-0.2-makefile.patch9
-rw-r--r--app-shells/prll/metadata.xml5
-rw-r--r--app-shells/prll/prll-0.2.ebuild27
5 files changed, 55 insertions, 0 deletions
diff --git a/app-shells/prll/ChangeLog b/app-shells/prll/ChangeLog
new file mode 100644
index 000000000..035b543f9
--- /dev/null
+++ b/app-shells/prll/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-shells/prll
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 08 Jan 2010; Jure Varlec (exzombie) <jure.varlec@gmail.com>
+ +prll-0.2.ebuild, +files/prll-0.2-makefile.patch, +metadata.xml:
+ New ebuild for bug #299798. Thanks to dilfridge and Tommy[D]. Also thanks to
+ Wizzleby for amd64 testing.
+
diff --git a/app-shells/prll/Manifest b/app-shells/prll/Manifest
new file mode 100644
index 000000000..9ffaaea57
--- /dev/null
+++ b/app-shells/prll/Manifest
@@ -0,0 +1,5 @@
+AUX prll-0.2-makefile.patch 220 RMD160 d5fd285ea07176805d9c2132b52a0ff09d8c19ce SHA1 98150674ae8edfa7d87cd7e9156006b5c60350b4 SHA256 4b4529b67ae4b962f17eaf61c69770a1fa7ab85a235871b268ee234eaed5fe16
+DIST prll-0.2.tar.bz2 15289 RMD160 1972c9b7af30c1ddbef72fabb856f458f015be32 SHA1 bbd045de3f78e58af399ff2d4ff099a5c62fecd7 SHA256 7d3b766b0fcace7411b5d8a8ba41bb06d50ed04a89dc506bb3574b49433453bb
+EBUILD prll-0.2.ebuild 617 RMD160 1168f262c34f74b9270c89841d4a03ddd01781c1 SHA1 7a00e4e67b7541883598fc561980fd53b5cdaee5 SHA256 74ec5e42a3301f8b8de82b5dd09565c03362113671be9c0606c42ce6c77d8737
+MISC ChangeLog 355 RMD160 a1d237299107593a24ff15a6c574459a11745d67 SHA1 be1f45063a21efa2572b140cf3f76708c29a1090 SHA256 f70016eea3a0ecb8517419c85a73c6922e5756cc468506797a5509ca30625645
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-shells/prll/files/prll-0.2-makefile.patch b/app-shells/prll/files/prll-0.2-makefile.patch
new file mode 100644
index 000000000..f4ff2d21f
--- /dev/null
+++ b/app-shells/prll/files/prll-0.2-makefile.patch
@@ -0,0 +1,9 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,5 @@
+-CFLAGS += --std=c99 -Wformat -pedantic -g -O2 -fomit-frame-pointer
++CFLAGS ?= -g -O2 -fomit-frame-pointer -Wformat -pedantic
++CFLAGS += --std=c99
+
+ .PHONY: clean compile
+
diff --git a/app-shells/prll/metadata.xml b/app-shells/prll/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-shells/prll/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/app-shells/prll/prll-0.2.ebuild b/app-shells/prll/prll-0.2.ebuild
new file mode 100644
index 000000000..0dc4b9e97
--- /dev/null
+++ b/app-shells/prll/prll-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A utility for parallelizing execution in bash or zsh"
+HOMEPAGE="http://prll.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 WTFPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/prll-0.2-makefile.patch
+}
+
+src_install() {
+ dobin ${PN}_jobserver || die "installation failed"
+ insinto /etc/profile.d/
+ doins ${PN}.sh || die "installation failed"
+ dodoc AUTHORS README || die "dodoc failed"
+}