summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb (moschlar) <mail@moritz-schlarb.de>2011-10-01 13:00:49 +0000
committerMoritz Schlarb (moschlar) <mail@moritz-schlarb.de>2011-10-01 13:00:49 +0000
commit8c15aef5d67c433bbd08af1cdfa53dc2912eb16b (patch)
treeced1c42e878291072b9a4589c62b1f49f3a3ebe7 /app-cdr
parentmedia-sound/mixxx: Added env vars for installation phase. (diff)
downloadsunrise-reviewed-8c15aef5d67c433bbd08af1cdfa53dc2912eb16b.tar.gz
sunrise-reviewed-8c15aef5d67c433bbd08af1cdfa53dc2912eb16b.tar.bz2
sunrise-reviewed-8c15aef5d67c433bbd08af1cdfa53dc2912eb16b.zip
app-cdr/furiusisomount: New Ebuild for bug 261362, thanks to Tommy[D], hwoarang, Hawk777 and _AxS_
svn path=/sunrise/; revision=12418
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/furiusisomount/ChangeLog8
-rw-r--r--app-cdr/furiusisomount/Manifest4
-rw-r--r--app-cdr/furiusisomount/furiusisomount-0.11.3.1.ebuild72
-rw-r--r--app-cdr/furiusisomount/metadata.xml10
4 files changed, 94 insertions, 0 deletions
diff --git a/app-cdr/furiusisomount/ChangeLog b/app-cdr/furiusisomount/ChangeLog
new file mode 100644
index 000000000..f8cfc6eb5
--- /dev/null
+++ b/app-cdr/furiusisomount/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-cdr/furiusisomount
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 01 Oct 2011; Moritz Schlarb (moschlar) <mail@moritz-schlarb.de>
+ +furiusisomount-0.11.3.1.ebuild, +metadata.xml:
+ New Ebuild for bug 261362, thanks to Tommy[D], hwoarang, Hawk777 and _AxS_
+
diff --git a/app-cdr/furiusisomount/Manifest b/app-cdr/furiusisomount/Manifest
new file mode 100644
index 000000000..2783bd095
--- /dev/null
+++ b/app-cdr/furiusisomount/Manifest
@@ -0,0 +1,4 @@
+DIST furiusisomount_0.11.3.1.tar.gz 267388 RMD160 97f7e9761c9e5a9060f3948e310ceee4048fac58 SHA1 2f6a30c779d07f991725bce7482dc7a396b787b2 SHA256 ea16ac56343e94e3563c447e0b9ecce7700ffbcd7d3c0d32c7792405f3c302a2
+EBUILD furiusisomount-0.11.3.1.ebuild 2081 RMD160 c1f76c29bf8edf6715a46c2b6ae2a1ef2d505370 SHA1 615e7c05c6ca4dc0770627c5aaa3d966727d7d48 SHA256 d29b70c4fe5690cc1bd79070f92fa71ca095224e6fbb4f71762dec7d4df86962
+MISC ChangeLog 317 RMD160 dade62fc39173c02d7be4879ce26f3eb56554b69 SHA1 c1f7346b1e44bf14edd1e95e0c772b418f3200c9 SHA256 5de0cdc899e516993a0489251e2f1bcfd193e91e982cef86dfce1a0e3d9a7873
+MISC metadata.xml 335 RMD160 862f7cddb248bcb26aacb850ed7a7a84b55264c8 SHA1 c67472e6426dd863352a09d639ed8c4a0f75fbc8 SHA256 b57f5eff0e17013c7813c71a444d35efb0a7178f2f334e5efc628a87deed6254
diff --git a/app-cdr/furiusisomount/furiusisomount-0.11.3.1.ebuild b/app-cdr/furiusisomount/furiusisomount-0.11.3.1.ebuild
new file mode 100644
index 000000000..4544f1d8d
--- /dev/null
+++ b/app-cdr/furiusisomount/furiusisomount-0.11.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="threads"
+
+inherit eutils python
+
+MY_P=${PN}_${PV}
+DESCRIPTION="Simple Gtk+ Interface to Mount ISO, IMG, BIN, MDF and NRG Image files without burning to disk"
+HOMEPAGE="http://www.marcus-furius.com/?page_id=170"
+SRC_URI="http://launchpad.net/${PN}/python/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="brasero"
+
+RDEPEND="dev-python/pygobject:2
+ dev-python/pygtk:2
+ sys-fs/fuseiso
+ gnome-base/nautilus
+ x11-libs/gksu
+ brasero? ( app-cdr/brasero )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # The tarball ships *.pyc files, but we don't want to install them, do we?
+ rm src/*.pyc || die "rm failed"
+
+ # Change python binary call and path to main in furiusisomount
+ sed -e 's:^python "\(src/main.py\)":'$(PYTHON -a)' "/usr/share/'${PN}'/\1":' -i ${PN} || die "sed failed"
+
+ # Disable the nautilus radio button because we can't use it anyway, Gentoo does not have nautilus-cd-burner
+ sed -e '/<widget class="GtkRadioButton" id="radiobutton_nautilus">/ a\
+ <property name="sensitive">False</property>' -i res/main_window.glade
+
+ # If brasero is disabled, we disable all burning-related widgets
+ if ! use brasero; then
+ sed -e '/<widget class="GtkRadioButton" id="radiobutton_brasero">/ a\
+ <property name="sensitive">False</property>' -i res/main_window.glade
+ sed -e "s/self.interface.get_widget('button_burn').set_sensitive(True)/#&/" -i src/main.py
+ fi
+
+ python_convert_shebangs -r 2 src
+}
+
+src_install() {
+ insinto /usr/share/${PN}/
+ doins -r src res po pix locale || die "doins failed"
+
+ dobin ${PN} || die "dobin failed"
+ doicon pix/${PN}.png || die "doicon failed"
+ newmenu app.desktop ${PN}.desktop || die "newmenu failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/src/
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/src/
+}
diff --git a/app-cdr/furiusisomount/metadata.xml b/app-cdr/furiusisomount/metadata.xml
new file mode 100644
index 000000000..0e5a2c9aa
--- /dev/null
+++ b/app-cdr/furiusisomount/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='brasero'>Enables support for burning images using <pkg>app-cdr/brasero</pkg></flag>
+ </use>
+</pkgmetadata>