aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-05 22:46:55 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-12-05 22:46:55 +0000
commit86d5953495a3abae4e1cfc7fadc2b575d589dc32 (patch)
treeda6f40defeac25508785a38ab77c0b7a0a3f5930 /sys-cluster
parentdev-python/numba: add updated patch (diff)
downloadsci-86d5953495a3abae4e1cfc7fadc2b575d589dc32.tar.gz
sci-86d5953495a3abae4e1cfc7fadc2b575d589dc32.tar.bz2
sci-86d5953495a3abae4e1cfc7fadc2b575d589dc32.zip
sys-cluster/Lmod: version bump to 8.4.16
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Lmod/Lmod-8.4.16.ebuild110
-rw-r--r--sys-cluster/Lmod/Manifest1
2 files changed, 111 insertions, 0 deletions
diff --git a/sys-cluster/Lmod/Lmod-8.4.16.ebuild b/sys-cluster/Lmod/Lmod-8.4.16.ebuild
new file mode 100644
index 000000000..fafdc2cd7
--- /dev/null
+++ b/sys-cluster/Lmod/Lmod-8.4.16.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Environment Module System based on Lua"
+HOMEPAGE="https://lmod.readthedocs.io/en/latest"
+SRC_URI="https://github.com/TACC/Lmod/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="auto-swap cache dotfiles duplicate +extend italic module-cmd nocase redirect test"
+RESTRICT="!test? ( test )"
+
+RDEPEND+="
+ app-shells/tcsh
+ || (
+ app-shells/loksh
+ app-shells/mksh
+ app-shells/ksh
+ )
+ app-shells/zsh
+ dev-lang/tcl
+ dev-lua/luafilesystem
+ dev-lua/luajson
+ dev-lua/luaposix
+ dev-lua/lua-term
+"
+DEPEND+="${RDEPEND}"
+BDEPEND+="
+ test? (
+ dev-util/Hermes
+ )
+"
+
+pkg_setup() {
+ elog "There is a lot of options for this package,"
+ elog "especially for run time behaviour."
+ elog "You can set them using EXTRA_ECONF variable."
+ elog "To see full list of options visit:"
+ elog "https://lmod.readthedocs.io/en/latest/090_configuring_lmod.html"
+}
+
+src_prepare() {
+ default
+
+ rm -r "${S}"/rt/{colorize,end2end,help,ifur,settarg} || die
+}
+
+src_configure() {
+ # set environment variables to pass to Lmod configuration
+ local -x CACHE_LIFETIME="${CACHE_LIFETIME:-86400}"
+ local -x SHORT_TIME="${SHORT_TIME:-2}"
+ local -x SYSTEM_TOUCH="${SYSTEM_TOUCH:-/var/lmod/latest_system_update.time}"
+ local -x SITE_NAME="${SITE_NAME:-Gentoo}"
+ local -x SYSHOST="${SYSHOST:-Gentoo}"
+
+ local myconf=(
+ --with-tcl
+ --with-fastTCLInterp
+ --with-colorize
+ --prefix=/opt
+ --with-ancient="${CACHE_LIFETIME}"
+ --with-supportKsh
+ --with-updateSystemFn="${SYSTEM_TOUCH}"
+ --with-siteName="${SITE_NAME}"
+ --with-syshost="${SYSHOST}"
+ --with-shortTime="${SHORT_TIME}"
+ --without-useBuiltinPkgs
+ $(use_with duplicate duplicatePaths)
+ $(use_with nocase caseIndependentSorting)
+ $(use_with italic hiddenItalic)
+ $(use_with auto-swap autoSwap)
+ $(use_with module-cmd exportedModuleCmd)
+ $(use_with redirect)
+ $(use_with dotfiles useDotFiles)
+ $(use_with cache cachedLoads)
+ $(use_with extend extendedDefault)
+ )
+
+ econf ${myconf[@]} ${EXTRA_ECONF[@]}
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ default
+}
+
+src_test() {
+ local -x PATH="/opt/hermes/bin:${PATH}"
+ tm -vvv || die
+}
+
+src_install() {
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ default
+
+ keepdir /var/lmod
+}
+
+pkg_postinst() {
+ elog "Lmod has been installed at /opt/lmod/{lmod -> ${PV}}"
+ elog "To activate Lmod, you need to source the profile"
+ elog "script provided"
+ elog " $ . /opt/lmod/lmod/init/profile"
+ elog "This will provide you with the 'module' command"
+ elog " $ man module"
+}
diff --git a/sys-cluster/Lmod/Manifest b/sys-cluster/Lmod/Manifest
index 43a5deebc..958efb0fe 100644
--- a/sys-cluster/Lmod/Manifest
+++ b/sys-cluster/Lmod/Manifest
@@ -1 +1,2 @@
DIST Lmod-8.4.11.tar.gz 19934772 BLAKE2B cc918e7e6f05cc0da882dec6f0472341cd779e64d1574a005cd531eb8a209c44b63d2fed4f50fc7b22fda0bdbf68fc3e8950bb170bc3d76f74824099be7227b2 SHA512 92c07be79455928229352ea5cd93f960a61456bcebc73e699ee996841b61bc3fe54a815b7bf0f996e12218bd6c66a6d1f2742bb65569626c45feb59f84f55191
+DIST Lmod-8.4.16.tar.gz 19948238 BLAKE2B 319633d7495ee9ea625474b57c11295ff2d05c46697327ff25d3fd79363c67aa0fa8a9d78bf00e93e3088b056edf7328da78e1c70fc8cf484e402cc8d8c66218 SHA512 ba34155a1386dec0743410016660561d036bf37a6b5b5374d46390d9ec546af68a62e29889376b8af1bc8f9b46d25fdc0db892bf412dc31946902c97af05bd4f