aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-03-20 08:10:54 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-03-20 11:22:27 +0100
commitc1dc06bee3b7aa287ba0d417a5676ad63c07d57e (patch)
tree7e2d5293cadcefcc3823a10a69f36f5f491f053c /sci-physics
parentsci-physics/scikit-hep-testdata: new package, add 0.4.39 (diff)
downloadsci-c1dc06bee3b7aa287ba0d417a5676ad63c07d57e.tar.gz
sci-c1dc06bee3b7aa287ba0d417a5676ad63c07d57e.tar.bz2
sci-c1dc06bee3b7aa287ba0d417a5676ad63c07d57e.zip
sci-physics/pylhe: new package, add 0.7.0, 0.8.0
Closes: https://github.com/gentoo/sci/pull/1262 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pylhe/Manifest2
-rw-r--r--sci-physics/pylhe/files/pylhe-0.7.0-coverage.patch8
-rw-r--r--sci-physics/pylhe/metadata.xml19
-rw-r--r--sci-physics/pylhe/pylhe-0.7.0.ebuild35
-rw-r--r--sci-physics/pylhe/pylhe-0.8.0.ebuild35
5 files changed, 99 insertions, 0 deletions
diff --git a/sci-physics/pylhe/Manifest b/sci-physics/pylhe/Manifest
new file mode 100644
index 000000000..11dbc6d26
--- /dev/null
+++ b/sci-physics/pylhe/Manifest
@@ -0,0 +1,2 @@
+DIST pylhe-0.7.0.gh.tar.gz 140203 BLAKE2B 6c167b37bb6c978752de79586e4f655169b5134c6cd7637807e649323ebaca50d8a360b1ca32eeff2cc162efe5e13d7de92f72d5a9263a7b2c48a5b87b7b919c SHA512 1a338ab4e1c5dd1d8d80e4a03ad84eb59f19ebb151a4b1393b68ee6ecade920c88db6cb940d56bd1f238e833f59b266507ab678124ea49b4086fe05b7f9baa88
+DIST pylhe-0.8.0.gh.tar.gz 144541 BLAKE2B 5c6a6511acd1adefad6bf3769fdb5ac2a528a8cc939bb1209d7fd4dc31eef9060d129c330b34e3cfc7b640c9b82f68f043e4604f3a535865240ceda0a33dd691 SHA512 6fc3c525cbb5f2ebe8678d1e03940fde8bdc837f1da6a667c70069584de476ea73c72e817cc84637e018ca7cf21e8bb0f7b2721fe54ef78a9b0eee7900ec400e
diff --git a/sci-physics/pylhe/files/pylhe-0.7.0-coverage.patch b/sci-physics/pylhe/files/pylhe-0.7.0-coverage.patch
new file mode 100644
index 000000000..ea678ce8c
--- /dev/null
+++ b/sci-physics/pylhe/files/pylhe-0.7.0-coverage.patch
@@ -0,0 +1,8 @@
+--- a/pytest.ini 2024-03-20 07:36:32.600030197 +0100
++++ b/pytest.ini 2024-03-20 07:36:45.896874886 +0100
+@@ -1,4 +1,4 @@
+ [pytest]
+ docstyle_convention = numpy
+ junit_family = xunit2
+-addopts = --ignore=setup.py --ignore=binder/ --ignore=docs/ --cov=pylhe --cov-report=term-missing --cov-config=.coveragerc --cov-report xml --doctest-modules --doctest-glob='*.rst'
++addopts = --ignore=setup.py --ignore=binder/ --ignore=docs/ --doctest-modules --doctest-glob='*.rst'
diff --git a/sci-physics/pylhe/metadata.xml b/sci-physics/pylhe/metadata.xml
new file mode 100644
index 000000000..86ede8deb
--- /dev/null
+++ b/sci-physics/pylhe/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ Small and thin Python interface to read Les Houches Event (LHE) files.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pylhe</remote-id>
+ <remote-id type="github">scikit-hep/pylhe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-physics/pylhe/pylhe-0.7.0.ebuild b/sci-physics/pylhe/pylhe-0.7.0.ebuild
new file mode 100644
index 000000000..45ef91695
--- /dev/null
+++ b/sci-physics/pylhe/pylhe-0.7.0.ebuild
@@ -0,0 +1,35 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lightweight Python interface to read Les Houches Event (LHE) files"
+HOMEPAGE="https://github.com/scikit-hep/pylhe"
+# pypi does not include tests
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+# export is needed here!
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/graphviz-0.12.0[${PYTHON_USEDEP}]
+ >=sci-physics/particle-0.16[${PYTHON_USEDEP}]
+ >=dev-python/awkward-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/vector-0.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=sci-physics/scikit-hep-testdata-0.4.36[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.7.0-coverage.patch
+)
+
+distutils_enable_tests pytest
diff --git a/sci-physics/pylhe/pylhe-0.8.0.ebuild b/sci-physics/pylhe/pylhe-0.8.0.ebuild
new file mode 100644
index 000000000..45ef91695
--- /dev/null
+++ b/sci-physics/pylhe/pylhe-0.8.0.ebuild
@@ -0,0 +1,35 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lightweight Python interface to read Les Houches Event (LHE) files"
+HOMEPAGE="https://github.com/scikit-hep/pylhe"
+# pypi does not include tests
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+# export is needed here!
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/graphviz-0.12.0[${PYTHON_USEDEP}]
+ >=sci-physics/particle-0.16[${PYTHON_USEDEP}]
+ >=dev-python/awkward-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/vector-0.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=sci-physics/scikit-hep-testdata-0.4.36[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.7.0-coverage.patch
+)
+
+distutils_enable_tests pytest