aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Mitrak <lucas@lucasmitrak.com>2021-08-05 17:10:07 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-06 10:38:37 +0200
commitfa7a1d7e6126d198b5e01ba98dd44b965f403aaa (patch)
tree3e12c90fbd5b2346e632051fae9be3df00504b36 /sci-mathematics
parentdev-libs/lief: do not allow both python and abi_x86_32 to be set (diff)
downloadsci-fa7a1d7e6126d198b5e01ba98dd44b965f403aaa.tar.gz
sci-fa7a1d7e6126d198b5e01ba98dd44b965f403aaa.tar.bz2
sci-fa7a1d7e6126d198b5e01ba98dd44b965f403aaa.zip
sci-mathematics/flocq: EAPI bump, add multiprocessing to remake
* EAPI bump from 7 to 8 * Add multiprocessing to remake using the $(makeopts_jobs) variable Currently, sci-mathematics/flocq does not have multiprocessing even though the homepage [1] states this is available. This is done by adding --jobs=$(makeopts_jobs) to remake. the makeopts_jobs variable comes from the multiprocessing eclass. [1] http://flocq.gforge.inria.fr/ Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Lucas Mitrak <lucas@lucasmitrak.com> Closes: https://github.com/gentoo/sci/pull/1107 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flocq/flocq-3.4.0-r1.ebuild (renamed from sci-mathematics/flocq/flocq-3.4.0.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-mathematics/flocq/flocq-3.4.0.ebuild b/sci-mathematics/flocq/flocq-3.4.0-r1.ebuild
index e629d5628..f0e6c73a8 100644
--- a/sci-mathematics/flocq/flocq-3.4.0.ebuild
+++ b/sci-mathematics/flocq/flocq-3.4.0-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit multiprocessing
DESCRIPTION="A floating-point formalization for the Coq system"
HOMEPAGE="http://flocq.gforge.inria.fr/"
@@ -26,7 +28,7 @@ src_configure() {
}
src_compile() {
- ./remake || die "emake failed"
+ ./remake --jobs=$(makeopts_jobs) || die "emake failed"
}
src_install() {