aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Luessi <mluessi@nmr.mgh.harvard.edu>2013-11-26 16:30:53 -0500
committerMartin Luessi <mluessi@nmr.mgh.harvard.edu>2013-11-26 16:30:53 -0500
commit736ca327827cde119169d41d3b569f27850092c6 (patch)
tree8fe8e28df50ccd8bc7688caa0f1d7d2af85f82e9 /sci-biology
parentMerge branch 'master' of github.com:gentoo-science/sci (diff)
downloadsci-736ca327827cde119169d41d3b569f27850092c6.tar.gz
sci-736ca327827cde119169d41d3b569f27850092c6.tar.bz2
sci-736ca327827cde119169d41d3b569f27850092c6.zip
Version bump: mne-python 0.7
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mne-python/Manifest1
-rw-r--r--sci-biology/mne-python/mne-python-0.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/mne-python/Manifest b/sci-biology/mne-python/Manifest
new file mode 100644
index 000000000..38d6e3b27
--- /dev/null
+++ b/sci-biology/mne-python/Manifest
@@ -0,0 +1 @@
+DIST v0.7.zip 58120981 SHA256 26711803c8068adc7f3c06997b6bd1e076fea170e9f87af3b488c51eb6e3caa9 SHA512 1221038daa9687e358c7b51aed969c0174e5ea979e35c2e2663a5d2795b751f837bb8e1f45fd12251f713b6b69a5c5086e8f07d417e23abfa4302562f271f774 WHIRLPOOL a44c067c02270285103ad978d2d1afbf46972ad39eeec77548d78bb1515bd4a22fca713c2e814d5b462b09ce3caad2696deda1b09f67ed9f3c8f0a74de3fdaee
diff --git a/sci-biology/mne-python/mne-python-0.7.ebuild b/sci-biology/mne-python/mne-python-0.7.ebuild
new file mode 100644
index 000000000..ad1fa8b95
--- /dev/null
+++ b/sci-biology/mne-python/mne-python-0.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python package for MEG and EEG data analysis"
+HOMEPAGE="http://martinos.org/mne/mne-python.html"
+SRC_URI="https://github.com/mne-tools/mne-python/archive/v${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test cuda"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-biology/pysurfer[${PYTHON_USEDEP}]
+ sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cuda? (
+ dev-python/pycuda[${PYTHON_USEDEP}]
+ dev-python/scikits-cuda[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ test? ( dev-python/nose ${RDEPEND} )
+"
+
+S="${WORKDIR}/mne-python-${PV}"
+
+run_test() {
+ PYTHONPATH=. MNE_SKIP_SAMPLE_DATASET_TESTS=1 nosetests -v mne
+}
+
+python_test() {
+ distutils_install_for_testing
+ esetup.py install --root="${T}/test-${EPYTHON}" --no-compile
+ # Link to test data that won't be included in the final installation
+ local TEST_DIR="${T}/test-${EPYTHON}/$(python_get_sitedir)"
+ cd ${S} || die
+ find . -type d -name data -exec ln -s ${S}/{} ${TEST_DIR}/{} \; || die
+ cd ${TEST_DIR} || die
+ VIRTUALX_COMMAND="run_test"
+ virtualmake
+}