aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Weiner <timeraider@gmx.at>2017-09-18 02:26:20 +0200
committerBenda Xu <heroxbd@gentoo.org>2017-12-17 13:23:08 +0900
commit62625ca33c86939528d51e276a2a8ff569fb09b1 (patch)
treecf73e9eb5cb716684a21e63b31a1744f3fb66f21 /dev-util
parentsci-biology/swissknife: version bump (diff)
downloadsci-62625ca33c86939528d51e276a2a8ff569fb09b1.tar.gz
sci-62625ca33c86939528d51e276a2a8ff569fb09b1.tar.bz2
sci-62625ca33c86939528d51e276a2a8ff569fb09b1.zip
Tree-clean: I do no longer maintain these ebuilds.
Closes: https://github.com/gentoo/sci/pull/812 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/emscripten-fastcomp/Manifest2
-rw-r--r--dev-util/emscripten-fastcomp/emscripten-fastcomp-1.37.9.ebuild54
-rw-r--r--dev-util/emscripten-fastcomp/files/1.37.9/CMakeLists.txt.patch10
-rw-r--r--dev-util/emscripten-fastcomp/files/1.37.9/Version.cpp.patch14
-rw-r--r--dev-util/emscripten-fastcomp/metadata.xml11
-rw-r--r--dev-util/emscripten/Manifest1
-rw-r--r--dev-util/emscripten/emscripten-1.37.9.ebuild73
-rw-r--r--dev-util/emscripten/files/1.37.9/emcc.patch16
-rw-r--r--dev-util/emscripten/files/1.37.9/emcmake.patch16
-rw-r--r--dev-util/emscripten/files/99emscripten1
-rw-r--r--dev-util/emscripten/files/emscripten.config56
-rw-r--r--dev-util/emscripten/files/hello_world.cpp5
-rw-r--r--dev-util/emscripten/metadata.xml11
13 files changed, 0 insertions, 270 deletions
diff --git a/dev-util/emscripten-fastcomp/Manifest b/dev-util/emscripten-fastcomp/Manifest
deleted file mode 100644
index b0605ea48..000000000
--- a/dev-util/emscripten-fastcomp/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST emscripten-fastcomp-1.37.9.tar.gz 31002138 SHA256 b17f205e363bf49306b35b3ecf79c78592397a98e86811411570b23177709abd SHA512 443d22163866a409b6218bb686d52b845051350ef4af546e2d52ffaca03ed363f3cbf8f8e61b7fc28c1e1007d7e2789bfd74d91159deff46e3c6e1913ffebf34 WHIRLPOOL c9f75ddf4dc1be672e4dd5283efda9d8abf4939d7c254e60c8d8f7a87612b943a6241b5547e38cb7b6c74a581b66440aae03c447ff8547141a5313aee49d4942
-DIST emscripten-fastcomp-clang-1.37.9.tar.gz 15201740 SHA256 52ada5ec30222c05d99ac1fab3befaae515d042bc03dff7e4fe5b62bc009fd75 SHA512 5c1fae88e87575571fef767f9c3d664c0eed106d566517871503c75cb5e31777d5fd5773f914fbe932abde3b42870b25e4ca58cf458ceecd0f9a7a50e7d86af9 WHIRLPOOL fc8e3f08b0ab36d4e9ff7573be345e044d41f97559db119223fa0d160ec178f324696956aa8b06f8143abbcce51d948a3beee6f4e100b23a0c8bbed0ca82abed
diff --git a/dev-util/emscripten-fastcomp/emscripten-fastcomp-1.37.9.ebuild b/dev-util/emscripten-fastcomp/emscripten-fastcomp-1.37.9.ebuild
deleted file mode 100644
index c4ffa8996..000000000
--- a/dev-util/emscripten-fastcomp/emscripten-fastcomp-1.37.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-DESCRIPTION="Emscripten LLVM backend - Fastcomp is the default compiler core for Emscripten"
-HOMEPAGE="http://emscripten.org/"
-SRC_URI="https://github.com/kripken/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/kripken/${PN}-clang/archive/${PV}.tar.gz -> ${PN}-clang-${PV}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="UoI-NCSA"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-MY_DEPEND="${PYTHON_DEPS}
- >=net-libs/nodejs-0.12.10"
-DEPEND="${MY_DEPEND}
- >=dev-util/cmake-3.4.3"
-RDEPEND="${MY_DEPEND}
- >=virtual/jre-1.5"
-
-src_prepare() {
- eapply "${FILESDIR}/${PV}/CMakeLists.txt.patch"
- cd "${S}/../${PN}-clang-${PV}" || \
- die "Could not change to directory '${S}/../${PN}-clang-${PV}'"
- eapply "${FILESDIR}/${PV}/Version.cpp.patch"
- cd "${S}" || die "Could not change to directory '${S}'"
- eapply_user
-}
-
-src_configure() {
- # create symlink to tools/clang
- ln -s "${WORKDIR}/${PN}-clang-${PV}/" "${WORKDIR}/${P}/tools/clang" \
- || die "Could not create symlink to tools/clang"
- local mycmakeargs=(
- # avoid clashes with sys-devel/llvm
- -DCMAKE_INSTALL_PREFIX="/usr/share/${P}"
- -DLLVM_OCAML_INSTALL_PATH="/usr/share/${P}/ocaml"
- -DLLVM_ENABLE_OCAMLDOC=OFF
- -DLLVM_TARGETS_TO_BUILD="X86;JSBackend"
- -DLLVM_INCLUDE_EXAMPLES=OFF
- -DLLVM_INCLUDE_TESTS=OFF
- -DCLANG_INCLUDE_EXAMPLES=OFF
- -DCLANG_INCLUDE_TESTS=OFF
- -DCLANG_INCLUDE_DOCS=OFF
- -DLLVM_INCLUDE_DOCS=OFF
- )
- cmake-utils_src_configure
-}
diff --git a/dev-util/emscripten-fastcomp/files/1.37.9/CMakeLists.txt.patch b/dev-util/emscripten-fastcomp/files/1.37.9/CMakeLists.txt.patch
deleted file mode 100644
index d053132a3..000000000
--- a/dev-util/emscripten-fastcomp/files/1.37.9/CMakeLists.txt.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/CMakeLists.txt.orig 2016-05-12 13:26:02.739443914 +0200
-+++ b/CMakeLists.txt 2016-05-12 13:26:26.448733236 +0200
-@@ -175,7 +175,7 @@
- string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
-
- if (CMAKE_BUILD_TYPE AND
-- NOT uppercase_CMAKE_BUILD_TYPE MATCHES "^(DEBUG|RELEASE|RELWITHDEBINFO|MINSIZEREL)$")
-+ NOT uppercase_CMAKE_BUILD_TYPE MATCHES "^(DEBUG|RELEASE|RELWITHDEBINFO|MINSIZEREL|GENTOO)$")
- message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
- endif()
diff --git a/dev-util/emscripten-fastcomp/files/1.37.9/Version.cpp.patch b/dev-util/emscripten-fastcomp/files/1.37.9/Version.cpp.patch
deleted file mode 100644
index 291a1ea6d..000000000
--- a/dev-util/emscripten-fastcomp/files/1.37.9/Version.cpp.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/lib/Basic/Version.cpp 2016-03-17 23:31:35.160129074 +0100
-+++ b/lib/Basic/Version.cpp 2016-03-17 23:32:07.722127712 +0100
-@@ -135,9 +135,9 @@
-
- // XXX EMSCRIPTEN: show our versions
- OS << " (emscripten "
--#include "../../../../emscripten-version.txt"
-+#include "../../emscripten-version.txt"
- " : "
--#include "../../../../tools/clang/emscripten-version.txt"
-+#include "../../emscripten-version.txt"
- ")";
-
- return OS.str();
diff --git a/dev-util/emscripten-fastcomp/metadata.xml b/dev-util/emscripten-fastcomp/metadata.xml
deleted file mode 100644
index 89b91870f..000000000
--- a/dev-util/emscripten-fastcomp/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>harald.weiner@jku.at</email>
- <name>Harald Weiner</name>
- </maintainer>
- <upstream>
- <remote-id type="github">kripken/emscripten-fastcomp-clang</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-util/emscripten/Manifest b/dev-util/emscripten/Manifest
deleted file mode 100644
index 0ba1e496e..000000000
--- a/dev-util/emscripten/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST emscripten-1.37.9.tar.gz 32242848 BLAKE2B 244cf7973b028e778492746afd086ebf1b9cc5dff8c96bc6fc187e076633af376ad8813cf2717dff2c451b757e7b40fd57a20897e70d92960e78988e4c0d5847 SHA512 0efd9035d3dce0726025b5b8e30129885eef30f915c502b8957150e4ffc11fd0e9a2b605854cdf69ca3eb05e5102bf34341b7edd2116f5fa29fd170a28e7f07f
diff --git a/dev-util/emscripten/emscripten-1.37.9.ebuild b/dev-util/emscripten/emscripten-1.37.9.ebuild
deleted file mode 100644
index 51a451856..000000000
--- a/dev-util/emscripten/emscripten-1.37.9.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="LLVM-to-JavaScript Compiler"
-HOMEPAGE="http://emscripten.org/"
-SRC_URI="https://github.com/kripken/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="UoI-NCSA"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- ~dev-util/emscripten-fastcomp-${PV}"
-RDEPEND="${DEPEND}"
-
-DEST="/usr/share/"
-TEST="${WORKDIR}/test/"
-
-prepare_file() {
- cp "${FILESDIR}/${1}" "${S}/" || die "could not copy '${1}'"
- sed -i "s/\${PV}/${PV}/g" "${S}/${1}" || \
- die "could not adjust path for '${1}'"
-}
-
-src_prepare() {
- prepare_file "99emscripten"
- prepare_file "emscripten.config"
- eapply "${FILESDIR}/${PV}/emcc.patch"
- eapply "${FILESDIR}/${PV}/emcmake.patch"
- eapply_user
-}
-
-src_test() {
- mkdir "${TEST}" || die "Could not create test directory!"
- cp "${FILESDIR}/hello_world.cpp" "${TEST}" || die "Could not copy example file"
- cp "${S}/emscripten.config" "${TEST}" || die "Could not copy config file"
- sed -i -e "/^EMSCRIPTEN_ROOT/s|/usr/share/|${S}|" \
- "${TEST}/emscripten.config" || die "Could not adjust path for testing"
- export EM_CONFIG="${TEST}/emscripten.config" || die "Could not export variable"
- ../"${P}/emcc" "${TEST}/hello_world.cpp" -o "${TEST}/hello_world.js" || \
- die "Error during executing emcc!"
- test -f "${TEST}/hello_world.js" || die "Could not find '${TEST}/hello_world.js'"
- OUT=$(/usr/bin/node "${TEST}/hello_world.js") || \
- die "Could not execute /usr/bin/node"
- EXP=$(echo -e -n 'Hello World!\n') || die "Could not create expected string"
- if [ "${OUT}" != "${EXP}" ]; then
- die "Expected '${EXP}' but got '${OUT}'!"
- fi
- rm -r "${TEST}" || die "Could not clean-up '${TEST}'"
-}
-
-src_install() {
- dodir ${DEST}/${P}
- cp -R "${S}/" "${D}/${DEST}" || die "Could not install files"
- dosym ../share/${P}/emcc /usr/bin/emcc
- dosym ../share/${P}/emcmake /usr/bin/emcmake
- doenvd 99emscripten
- ewarn "If you consider using emscripten in an active shell,"\
- "please execute 'source /etc/profile'"
-}
-
-pkg_postinst() {
- elog "Running emscripten initialization, may take a few seconds..."
- export EM_CONFIG="${DEST}/${P}/emscripten.config" || die "Could not export variable"
- /usr/bin/emcc -v || die "Could not run emcc initialization"
-}
diff --git a/dev-util/emscripten/files/1.37.9/emcc.patch b/dev-util/emscripten/files/1.37.9/emcc.patch
deleted file mode 100644
index 49bf9fd0b..000000000
--- a/dev-util/emscripten/files/1.37.9/emcc.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/emcc.orig 2016-05-13 02:59:24.977645718 +0200
-+++ b/emcc 2016-05-13 03:00:22.778643301 +0200
-@@ -4,6 +4,7 @@
-
-
- import sys
-+import os
-
-
-
-@@ -14,4 +15,4 @@
- else:
- import os, subprocess
- if __name__ == '__main__':
-- sys.exit(subprocess.call(['python2', os.path.join(os.path.dirname(__file__), 'emcc.py')] + sys.argv[1:]))
-+ sys.exit(subprocess.call(['python2', os.path.join(os.path.dirname(os.environ['EM_CONFIG']), 'emcc.py')] + sys.argv[1:]))
diff --git a/dev-util/emscripten/files/1.37.9/emcmake.patch b/dev-util/emscripten/files/1.37.9/emcmake.patch
deleted file mode 100644
index 02ce70321..000000000
--- a/dev-util/emscripten/files/1.37.9/emcmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/emcmake.orig 2016-05-13 02:59:31.244645456 +0200
-+++ b/emcmake 2016-05-13 03:03:54.995634425 +0200
-@@ -4,6 +4,7 @@
-
-
- import sys
-+import os
-
-
-
-@@ -14,4 +15,4 @@
- else:
- import os, subprocess
- if __name__ == '__main__':
-- sys.exit(subprocess.call(['python2', os.path.join(os.path.dirname(__file__), 'emcmake.py')] + sys.argv[1:]))
-+ sys.exit(subprocess.call(['python2', os.path.join(os.path.dirname(os.environ['EM_CONFIG']), 'emcmake.py')] + sys.argv[1:]))
diff --git a/dev-util/emscripten/files/99emscripten b/dev-util/emscripten/files/99emscripten
deleted file mode 100644
index b1acf2a71..000000000
--- a/dev-util/emscripten/files/99emscripten
+++ /dev/null
@@ -1 +0,0 @@
-EM_CONFIG=/usr/share/emscripten-${PV}/emscripten.config
diff --git a/dev-util/emscripten/files/emscripten.config b/dev-util/emscripten/files/emscripten.config
deleted file mode 100644
index e8a4d7a0e..000000000
--- a/dev-util/emscripten/files/emscripten.config
+++ /dev/null
@@ -1,56 +0,0 @@
-
-# Note: If you put paths relative to the home directory, do not forget os.path.expanduser
-
-# Note: On Windows, remember to escape backslashes! I.e. EMSCRIPTEN_ROOT='c:\emscripten\' is not valid, but EMSCRIPTEN_ROOT='c:\\emscripten\\' and EMSCRIPTEN_ROOT='c:/emscripten/' are.
-
-import os
-
-# this helps projects using emscripten find it
-EMSCRIPTEN_ROOT = os.path.expanduser(os.getenv('EMSCRIPTEN') or '/usr/share/emscripten-${PV}') # directory
-LLVM_ROOT = os.path.expanduser(os.getenv('LLVM') or '/usr/share/emscripten-fastcomp-${PV}/bin') # directory
-
-# If not specified, defaults to sys.executable.
-#PYTHON = 'python'
-
-# Add this if you have manually built the JS optimizer executable (in Emscripten/tools/optimizer) and want to run it from a custom location.
-# Alternatively, you can set this as the environment variable EMSCRIPTEN_NATIVE_OPTIMIZER.
-# EMSCRIPTEN_NATIVE_OPTIMIZER='/path/to/custom/optimizer(.exe)'
-
-# See below for notes on which JS engine(s) you need
-NODE_JS = os.path.expanduser(os.getenv('NODE') or '/usr/bin/node') # executable
-SPIDERMONKEY_ENGINE = [os.path.expanduser(os.getenv('SPIDERMONKEY') or 'js')] # executable
-V8_ENGINE = os.path.expanduser(os.getenv('V8') or 'd8') # executable
-
-JAVA = 'java' # executable
-
-TEMP_DIR = '/tmp'
-
-CRUNCH = os.path.expanduser(os.getenv('CRUNCH') or 'crunch') # executable
-
-#CLOSURE_COMPILER = '..' # define this to not use the bundled version
-
-########################################################################################################
-
-
-# Pick the JS engine to use for running the compiler. This engine must exist, or
-# nothing can be compiled.
-#
-# Recommendation: If you already have node installed, use that. Otherwise, build v8 or
-# spidermonkey from source. Any of these three is fine, as long as it's
-# a recent version (especially for v8 and spidermonkey).
-
-COMPILER_ENGINE = NODE_JS
-#COMPILER_ENGINE = V8_ENGINE
-#COMPILER_ENGINE = SPIDERMONKEY_ENGINE
-
-
-# All JS engines to use when running the automatic tests. Not all the engines in this list
-# must exist (if they don't, they will be skipped in the test runner).
-#
-# Recommendation: If you already have node installed, use that. If you can, also build
-# spidermonkey from source as well to get more test coverage (node can't
-# run all the tests due to node issue 1669). v8 is currently not recommended
-# here because of v8 issue 1822.
-
-JS_ENGINES = [NODE_JS] # add this if you have spidermonkey installed too, SPIDERMONKEY_ENGINE]
-
diff --git a/dev-util/emscripten/files/hello_world.cpp b/dev-util/emscripten/files/hello_world.cpp
deleted file mode 100644
index 85daba3e4..000000000
--- a/dev-util/emscripten/files/hello_world.cpp
+++ /dev/null
@@ -1,5 +0,0 @@
-#include <iostream>
-int main(int argc, char ** argv) {
- std::cout << "Hello World!" << std::endl;
-}
-
diff --git a/dev-util/emscripten/metadata.xml b/dev-util/emscripten/metadata.xml
deleted file mode 100644
index b2ee118ca..000000000
--- a/dev-util/emscripten/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>harald.weiner@jku.at</email>
- <name>Harald Weiner</name>
- </maintainer>
- <upstream>
- <remote-id type="github">kripken/emscripten</remote-id>
- </upstream>
-</pkgmetadata>