aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-08-02 01:26:55 -0400
committerHorea Christian <chr@chymera.eu>2024-08-02 01:26:55 -0400
commit90a3d14b6a6418040654ed66497646d2e172f5df (patch)
treee7dfb47d41d2d40d87ffb3d177a03948d70de43d
parentdev-python/nwb2bids: new package, add 0.0.3 (diff)
downloadsci-90a3d14b6a6418040654ed66497646d2e172f5df.tar.gz
sci-90a3d14b6a6418040654ed66497646d2e172f5df.tar.bz2
sci-90a3d14b6a6418040654ed66497646d2e172f5df.zip
dev-python/annexremote: version bump
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/annexremote/Manifest1
-rw-r--r--dev-python/annexremote/annexremote-1.5.0.ebuild2
-rw-r--r--dev-python/annexremote/annexremote-1.6.0.ebuild2
-rw-r--r--dev-python/annexremote/annexremote-1.6.5.ebuild27
4 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/annexremote/Manifest b/dev-python/annexremote/Manifest
index c5eac671a..99145a13c 100644
--- a/dev-python/annexremote/Manifest
+++ b/dev-python/annexremote/Manifest
@@ -1,2 +1,3 @@
DIST annexremote-1.5.0.tar.gz 73544 BLAKE2B f5b528faf3d390f9bba6fb97768318ab04224cf05941a2606d49edda7bde30d743bf8e492f277986c0eda62f4000e1446e048d932df436cc2075b1f3e536c7d2 SHA512 7307f5ead82d449eda8b27a83f314b112bfe243a50f556397aed0f563452db6b4ba06b68aacaa27ff722ec9ccd2bdc489a3a8f4f3d849354757bd2fff8ae50d0
DIST annexremote-1.6.0.tar.gz 74199 BLAKE2B 27956c5ea4789a1bd22bfabe6e0da8a5c8700ba50c3c28610b364d6b358f195124667381094c7786a825fae4464a340b36fd61cd09956477101c7bfd54ba8166 SHA512 1320e06fb3bebe65cce872af6adfb702d9d44cad1671ab8fd432137eb44f22cbd35744b889f11900379da2512fb79da0972c0326fcf3e51c6a404fe497e20ea4
+DIST annexremote-1.6.5.gh.tar.gz 49349 BLAKE2B 226c80c41205da14f03b69d94142f5d39abad46aaa8bb84bbb98a83aa0bdc03df908316f3bef0ef6c425d775dc6b63732319bbec8c7ddffbbfcb3b55b84a8f8c SHA512 067d7371ddb0955ad95e208f5bfc22e5c9d3ba48a694794da0eeab6c2fd5523d32ff4bf53b7e33ecefb86629a1395d29d7e30e2b09880ced295745431acd178d
diff --git a/dev-python/annexremote/annexremote-1.5.0.ebuild b/dev-python/annexremote/annexremote-1.5.0.ebuild
index a6dacd5c9..c2fc5bb4f 100644
--- a/dev-python/annexremote/annexremote-1.5.0.ebuild
+++ b/dev-python/annexremote/annexremote-1.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
DESCRIPTION="Helper module to easily develop git-annex remotes"
diff --git a/dev-python/annexremote/annexremote-1.6.0.ebuild b/dev-python/annexremote/annexremote-1.6.0.ebuild
index a6dacd5c9..c2fc5bb4f 100644
--- a/dev-python/annexremote/annexremote-1.6.0.ebuild
+++ b/dev-python/annexremote/annexremote-1.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
DESCRIPTION="Helper module to easily develop git-annex remotes"
diff --git a/dev-python/annexremote/annexremote-1.6.5.ebuild b/dev-python/annexremote/annexremote-1.6.5.ebuild
new file mode 100644
index 000000000..8397d547c
--- /dev/null
+++ b/dev-python/annexremote/annexremote-1.6.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Helper module to easily develop git-annex remotes"
+HOMEPAGE="https://github.com/Lykos153/AnnexRemote"
+SRC_URI="https://github.com/Lykos153/AnnexRemote/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc README.md
+ use examples && dodoc -r examples
+}
+
+S="${WORKDIR}/AnnexRemote-${PV}"
+
+distutils_enable_tests pytest