aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/safe_yaml/safe_yaml-1.0.1.ebuild')
-rw-r--r--dev-ruby/safe_yaml/safe_yaml-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/safe_yaml/safe_yaml-1.0.1.ebuild b/dev-ruby/safe_yaml/safe_yaml-1.0.1.ebuild
new file mode 100644
index 0000000..d54aeda
--- /dev/null
+++ b/dev-ruby/safe_yaml/safe_yaml-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/safe_yaml/safe_yaml-0.9.7-r2.ebuild,v 1.1 2013/11/20 14:48:15 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse YAML safely, without that pesky arbitrary object deserialization vulnerability"
+HOMEPAGE="https://dtao.github.com/safe_yaml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hashie
+ dev-ruby/heredoc_unindent
+ dev-ruby/rspec:2 )"
+
+each_ruby_test() {
+ # Run specs with monkeypatch
+ ${RUBY} -S rspec --tag ~libraries || die
+
+ # Running specs without monkeypatch
+ ${RUBY} -S rspec --tag libraries || die
+}