aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2016-05-22 08:32:10 +0200
committerHans de Graaff <hans@degraaff.org>2016-05-22 08:32:10 +0200
commit9b0a1fa0d2600f3e64ea830cba1436c0589e22f0 (patch)
tree11f4914e23611c3769869a9eb3b7a2f345c3e263
parent.travis.yml: Update. (diff)
downloadruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.tar.gz
ruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.tar.bz2
ruby-overlay-9b0a1fa0d2600f3e64ea830cba1436c0589e22f0.zip
dev-ruby/pmap: initial import for ruby-tinderbox
Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/pmap/Manifest1
-rw-r--r--dev-ruby/pmap/metadata.xml11
-rw-r--r--dev-ruby/pmap/pmap-1.1.1.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/pmap/Manifest b/dev-ruby/pmap/Manifest
new file mode 100644
index 0000000..02820f2
--- /dev/null
+++ b/dev-ruby/pmap/Manifest
@@ -0,0 +1 @@
+DIST pmap-1.1.1.gem 9728 SHA256 c438e5bfc74e199978c72ee0798e98b5ac27a7600312b1d3519540bc0a151844 SHA512 af5b7e7afe4aaf7c01efa6e36e3f699d8456906827b4332f387884a28b3cd6e698b85cbf174a8e3eb914738ce1381bbb3c451d1cf766f6bf4305410138bd0a8d WHIRLPOOL d182e8b6e56ca13ba447c67cafa8daf9899b9c8549d58faae7cdcfab6fadc4c638973c17e74a1d2ac8a7e6fd1c3d4d17e9ec50e4b893240f49c8bf6a2909ed04
diff --git a/dev-ruby/pmap/metadata.xml b/dev-ruby/pmap/metadata.xml
new file mode 100644
index 0000000..e326491
--- /dev/null
+++ b/dev-ruby/pmap/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bruceadams/pmap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pmap/pmap-1.1.1.ebuild b/dev-ruby/pmap/pmap-1.1.1.ebuild
new file mode 100644
index 0000000..039cfcc
--- /dev/null
+++ b/dev-ruby/pmap/pmap-1.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add parallel methods into Enumerable: pmap and peach"
+HOMEPAGE="https://github.com/bruceadams/pmap"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"