summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-06-20 19:08:49 +0000
committerJim Ramsay <lack@gentoo.org>2007-06-20 19:08:49 +0000
commita753519bd1120ce06d4ffa64ff7c32288395b81f (patch)
tree138dd58b2c665b5b62bca3712a0ee3816ee48a48
parentNew release from upstread that has the official implementation of native feeds (diff)
downloadrox-a753519bd1120ce06d4ffa64ff7c32288395b81f.tar.gz
rox-a753519bd1120ce06d4ffa64ff7c32288395b81f.tar.bz2
rox-a753519bd1120ce06d4ffa64ff7c32288395b81f.zip
Updated to use actual upstream native_feed instead of our custom local_Feed
svn path=/trunk/overlay/; revision=10
-rw-r--r--eclass/0install.eclass20
-rw-r--r--eclass/rox.eclass28
-rw-r--r--rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild9
-rw-r--r--rox-base/rox-lib/rox-lib-2.0.4-r1.ebuild2
-rw-r--r--rox-base/rox/rox-2.6.1-r1.ebuild2
5 files changed, 28 insertions, 33 deletions
diff --git a/eclass/0install.eclass b/eclass/0install.eclass
index 303371a..857e2e4 100644
--- a/eclass/0install.eclass
+++ b/eclass/0install.eclass
@@ -11,7 +11,7 @@
RDEPEND="rox-base/zeroinstall-injector"
# Environment:
-LOCAL_FEED_DIR="/etc/xdg/0install.net/local_feeds"
+NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
ZEROINSTALL_STRIP_REQUIRES=""
# Escapes a http-style URI into a 0install-compatible filename
@@ -20,8 +20,8 @@ ZEROINSTALL_STRIP_REQUIRES=""
# uri - The URI to escape
0install_escape_uri() {
local uri=${1}
- uri=${uri//:/%3a}
- uri=${uri//\//%2f}
+ #uri=${uri//:/%3a}
+ uri=${uri//\/#}
echo $uri
}
@@ -64,17 +64,17 @@ ZEROINSTALL_STRIP_REQUIRES=""
-e "s/id='[^']*'/id=\".\" stability=\"packaged\"/" \
-e 's/main="[^"]*"/main="AppRun"/' \
-e "s/main='[^']*'/main=\"AppRun\"/" \
- ${input} > tmp.local_feed
+ ${input} > tmp.native_feed
if [[ -n "${ZEROINSTALL_STRIP_REQUIRES}" ]]; then
# Strip out all 'requires' sections
sed -i -e '/<requires.*\/>/d' \
- -e '/<requires.*\>/,/<\/requires>/d' tmp.local_feed
+ -e '/<requires.*\>/,/<\/requires>/d' tmp.native_feed
fi
(
insinto $(dirname ${output})
- newins tmp.local_feed $(basename ${output})
+ newins tmp.native_feed $(basename ${output})
)
}
@@ -101,7 +101,7 @@ ZEROINSTALL_STRIP_REQUIRES=""
# Step 3: Install the symlink so 0install can find it
local feedname=$(0install_escape_uri ${uri})
- dosym "${dest}" "${LOCAL_FEED_DIR}/${feedname}"
+ dosym "${dest}" "${NATIVE_FEED_DIR}/${feedname}"
}
# Does all the local feed magic you could want:
@@ -113,11 +113,11 @@ ZEROINSTALL_STRIP_REQUIRES=""
# ZEROINSTALL_STRIP_REQUIRES - If set, strips all 'requires' sections from the XML
# on editing. Default: Not set
#
-# 0install_local_feed <src> <destpath>
+# 0install_native_feed <src> <destpath>
# src - The XML file we will edit, install, and point at
# path - The path where the implementation will be installed
# IE, the final edited xml will be at <path>/<basename of src>
-0install_local_feed() {
+0install_native_feed() {
local src="${1}"; shift
local path="${1}"; shift
local feedfile=$(basename "${src}")
@@ -131,7 +131,7 @@ ZEROINSTALL_STRIP_REQUIRES=""
# Step 3: Install the symlink so 0install can find it
local feedname=$(0install_escape_uri ${uri})
- dosym "${dest}" "${LOCAL_FEED_DIR}/${feedname}"
+ dosym "${dest}" "${NATIVE_FEED_DIR}/${feedname}"
}
diff --git a/eclass/rox.eclass b/eclass/rox.eclass
index 1df348e..ac1f624 100644
--- a/eclass/rox.eclass
+++ b/eclass/rox.eclass
@@ -49,7 +49,7 @@
# need python to byte compile modules, if any
# need autotools to run autoreconf, if required
-inherit multilib python autotools eutils # 0install
+inherit multilib python autotools eutils 0install
if [[ -z "${ROX_VER}" ]]; then
ROX_VER="2.1.0"
@@ -256,19 +256,19 @@ EOF
fi
# TODO: Once 0install actually works, we'll want this, or something like it:
- #if [[ -f "${LOCAL_FEED_SRC}" ]]; then
- # # Install the ebuild-supplied feed
- # 0install_install_feed "${LOCAL_FEED_SRC}" "${APPDIR}/${APPNAME}"
- #else
- # # Install the local feed, if appropriate
- # local search_list=${FEED_FILES:-"${APPNAME}/${APPNAME}.xml ${APPNAME}.xml"}
- # for feed in ${search_list}; do
- # elog "Looking for feed $feed"
- # if [[ -f "${feed}" ]]; then
- # 0install_local_feed "${feed}" "${APPDIR}/${APPNAME}"
- # fi
- # done
- #fi
+ if [[ -f "${LOCAL_FEED_SRC}" ]]; then
+ # Install the ebuild-supplied feed
+ 0install_install_feed "${LOCAL_FEED_SRC}" "${APPDIR}/${APPNAME}"
+ else
+ # Install the local feed, if appropriate
+ local search_list=${FEED_FILES:-"${APPNAME}/${APPNAME}.xml ${APPNAME}.xml"}
+ for feed in ${search_list}; do
+ elog "Looking for feed $feed"
+ if [[ -f "${feed}" ]]; then
+ 0install_native_feed "${feed}" "${APPDIR}/${APPNAME}"
+ fi
+ done
+ fi
#now compile any and all python files
python_mod_optimize "${D}${APPDIR}/${APPNAME}" >/dev/null 2>&1
diff --git a/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild b/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild
index 4cee664..5c3277b 100644
--- a/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild
+++ b/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild
@@ -50,13 +50,8 @@ src_install() {
cp -r . ${D}${baselibdir}/${APPNAME}
(
cd Help
- dodoc Authors Changes ToDo COPYING README Versions
+ dodoc Authors Changes ToDo README Versions
)
- #finally link the html and latex dirs
- #cd ${D}/usr/share/doc/${P}
- #ln -s ${baselibdir}/${APPNAME}/Help/rox-clib.html rox-clib.html
- #ln -s ${baselibdir}/${APPNAME}/Help/libdir.html libdir.html
- #ln -s ${baselibdir}/${APPNAME}/Help/html html
- 0install_local_feed ${APPNAME}.xml "${baselibdir}/${APPNAME}"
+ 0install_native_feed ${APPNAME}.xml "${baselibdir}/${APPNAME}"
}
diff --git a/rox-base/rox-lib/rox-lib-2.0.4-r1.ebuild b/rox-base/rox-lib/rox-lib-2.0.4-r1.ebuild
index 0b8347c..3a712ad 100644
--- a/rox-base/rox-lib/rox-lib-2.0.4-r1.ebuild
+++ b/rox-base/rox-lib/rox-lib-2.0.4-r1.ebuild
@@ -28,5 +28,5 @@ src_install() {
dodir /usr/share/doc/
dosym ${baselibdir}/ROX-Lib2/Help /usr/share/doc/${P}
- 0install_local_feed ROX-Lib2/ROX-Lib2.xml ${baselibdir}/ROX-Lib2
+ 0install_native_feed ROX-Lib2/ROX-Lib2.xml ${baselibdir}/ROX-Lib2
}
diff --git a/rox-base/rox/rox-2.6.1-r1.ebuild b/rox-base/rox/rox-2.6.1-r1.ebuild
index 5d4ec6f..fab6c56 100644
--- a/rox-base/rox/rox-2.6.1-r1.ebuild
+++ b/rox-base/rox/rox-2.6.1-r1.ebuild
@@ -118,7 +118,7 @@ EOF
make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME}.png "System;Utility;Core;ROX"
- 0install_local_feed "${APPNAME}.xml" "${APPDIR}/${APPNAME}"
+ 0install_native_feed "${APPNAME}.xml" "${APPDIR}/${APPNAME}"
}
pkg_postinst() {