aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-02-19 01:10:08 +0200
committerJimi Huotari <chiitoo@gentoo.org>2019-02-19 01:20:15 +0200
commitf5201d1f33e0ae04ff2aa5ed24022c9c6dfdcf27 (patch)
treea79d5ed94c5d6542949cbaf0c03606522f86cdf8 /media-gfx/lximage-qt
parentx11-themes/lxqt-themes: add 0.14.0 for testing (diff)
downloadqt-f5201d1f33e0ae04ff2aa5ed24022c9c6dfdcf27.tar.gz
qt-f5201d1f33e0ae04ff2aa5ed24022c9c6dfdcf27.tar.bz2
qt-f5201d1f33e0ae04ff2aa5ed24022c9c6dfdcf27.zip
media-gfx/lximage-qt: add 0.14.0 for testing
Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-gfx/lximage-qt')
-rw-r--r--media-gfx/lximage-qt/Manifest1
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.14.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
new file mode 100644
index 00000000..1d07c7b2
--- /dev/null
+++ b/media-gfx/lximage-qt/Manifest
@@ -0,0 +1 @@
+DIST lximage-qt-0.14.0.tar.xz 77624 BLAKE2B 5ef8c30b397f22a167b9f9f20fa832b04ac9bde4218d10f80a182d1781138b3b6fcce4e22f7c2b49c0e6d59a08ec9683839989b41c9faa91db997a71bbe98864 SHA512 fddf4656f9112e02bb208b7c327d8f1a40326c1b5c9bff1cbd65909e808652c81dcdf5d2b9cf9cffd03c9e82b4980b498337afcb8fb1ee32ca7a7814ef268a0d
diff --git a/media-gfx/lximage-qt/lximage-qt-0.14.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.14.0.ebuild
new file mode 100644
index 00000000..a1dc7bd2
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.14.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-1.2:=
+ >=x11-libs/libfm-qt-0.12.0:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+ !lxqt-base/lxqt-l10n
+"
+DEPEND="${RDEPEND}"