aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-07-10 18:25:29 +0100
committerMarkos Chandras <hwoarang@gentoo.org>2012-07-10 18:25:29 +0100
commit9ca1c9b46ff2c0c0f19095805d3abf8d1778b6ce (patch)
tree3837e6999fbb5b6d2314b06ac810578171b9f0af /Documentation
parentdev-python/sip: Remove old ebuilds (diff)
downloadqt-9ca1c9b46ff2c0c0f19095805d3abf8d1778b6ce.tar.gz
qt-9ca1c9b46ff2c0c0f19095805d3abf8d1778b6ce.tar.bz2
qt-9ca1c9b46ff2c0c0f19095805d3abf8d1778b6ce.zip
bump-python-revisions: Make sure old files are gone
Diffstat (limited to 'Documentation')
-rwxr-xr-xDocumentation/maintainers/bump-python-revisions2
1 files changed, 2 insertions, 0 deletions
diff --git a/Documentation/maintainers/bump-python-revisions b/Documentation/maintainers/bump-python-revisions
index 47a77711..3a36f306 100755
--- a/Documentation/maintainers/bump-python-revisions
+++ b/Documentation/maintainers/bump-python-revisions
@@ -37,6 +37,7 @@ dosip(){
tomove=$(find '.' -type f -name "sip-*_pre*.ebuild"|tail -1)
einfo "Previous ebuild: ${tomove#./}"
mv ${tomove#./} sip-${new_sip_ver}_pre${DATE}.ebuild || exit "Failed to bump sip"
+ git rm ${tomove}
ebegin "Changing revision number to: ${new_sip_rev}"
sed -i "/^HG_REVISION/s:=.*:=${new_sip_rev}:" sip-${new_sip_ver}_pre${DATE}.ebuild
eend $?
@@ -57,6 +58,7 @@ dopyqt4(){
tomove=$(find '.' -type f -name "PyQt4-*_pre*.ebuild"|tail -1)
einfo "Previous ebuild: ${tomove#./}"
mv ${tomove#./} PyQt4-${new_pyqt4_ver}_pre${DATE}.ebuild || exit "Failed to bump PyQt4"
+ git rm ${tomove}
ebegin "Changing revision number to: ${new_pyqt4_rev}"
sed -i "/^REVISION/s:=.*:=${new_pyqt4_rev}:" PyQt4-${new_pyqt4_ver}_pre${DATE}.ebuild
eend $?